summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-31 14:40:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-31 14:40:29 +0200
commit1a24f855c8dcb61f34b1ec7390ca90e2540c53d9 (patch)
treec826ed66e6a858bb85114f742d922469de9a8761 /gnu/packages/bioconductor.scm
parent81e3de01ae2ac0e9cedc5625d25fd9b3d31e07fa (diff)
downloadpatches-1a24f855c8dcb61f34b1ec7390ca90e2540c53d9.tar
patches-1a24f855c8dcb61f34b1ec7390ca90e2540c53d9.tar.gz
gnu: Add r-birta.
* gnu/packages/bioconductor.scm (r-birta): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 10a4079fea..5ffb7c4e3c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4577,3 +4577,32 @@ respect to the original network. It includes functions for the analysis of
the introduced randomness across the switching steps and several other
routines to analyse the resulting networks and their natural projections.")
(license license:gpl3)))
+
+(define-public r-birta
+ (package
+ (name "r-birta")
+ (version "1.28.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "birta" version))
+ (sha256
+ (base32
+ "12xjyvgmh4h0b7hi4qg50kcpb9003gnh2xyfgncb8l9mzvsbkxc2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-limma" ,r-limma)
+ ("r-mass" ,r-mass)))
+ (home-page "https://bioconductor.org/packages/birta")
+ (synopsis "Bayesian inference of regulation of transcriptional activity")
+ (description
+ "Expression levels of mRNA molecules are regulated by different
+processes, comprising inhibition or activation by transcription factors and
+post-transcriptional degradation by microRNAs. @dfn{birta} (Bayesian
+Inference of Regulation of Transcriptional Activity) uses the regulatory
+networks of transcription factors and miRNAs together with mRNA and miRNA
+expression data to predict switches in regulatory activity between two
+conditions. A Bayesian network is used to model the regulatory structure and
+Markov-Chain-Monte-Carlo is applied to sample the activity states.")
+ (license license:gpl2+)))