summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-12 23:23:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-12 23:35:19 +0100
commitd220babf34d4e968159a6fd8165d0deeaa49905c (patch)
tree9079ef01d85f9d75d594bed1476e279dfcf542a4 /gnu/packages/bioconductor.scm
parentcad6fb2dec67e41498ee4cf9026ea5d12d8050e6 (diff)
downloadpatches-d220babf34d4e968159a6fd8165d0deeaa49905c.tar
patches-d220babf34d4e968159a6fd8165d0deeaa49905c.tar.gz
gnu: Add r-txdb-mmusculus-ucsc-mm9-knowngene.
* gnu/packages/bioconductor.scm (r-txdb-mmusculus-ucsc-mm9-knowngene): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0ded2a7b67..32391d6d4b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -197,6 +197,36 @@ default." )
genomes and gene ID formats, largely based on the UCSC table browser.")
(license license:lgpl2.0+)))
+(define-public r-txdb-mmusculus-ucsc-mm9-knowngene
+ (package
+ (name "r-txdb-mmusculus-ucsc-mm9-knowngene")
+ (version "3.2.2")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "https://bioconductor.org/packages/"
+ "release/data/annotation/src/contrib"
+ "/TxDb.Mmusculus.UCSC.mm9.knownGene_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "16bjxy00363hf91ik2mqlqls86i07gia72qh92xc3l1ncch61mx2"))))
+ (properties
+ `((upstream-name . "TxDb.Mmusculus.UCSC.mm9.knownGene")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-annotationdbi" ,r-annotationdbi)))
+ (home-page
+ "https://bioconductor.org/packages/TxDb.Mmusculus.UCSC.mm9.knownGene/")
+ (synopsis "Annotation package for mouse genome in TxDb format")
+ (description
+ "This package provides an annotation database of Mouse genome data. It
+is derived from the UCSC mm9 genome and based on the \"knownGene\" track. The
+database is exposed as a @code{TxDb} object.")
+ (license license:artistic2.0)))
+
(define-public r-hpar
(package