summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 13:16:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 13:17:52 +0100
commitf4eac09653ddebbe57e16824da42aad04af35632 (patch)
tree1de510b2600f2b3b67bfc96795aca23efa518c06 /gnu/packages/bioconductor.scm
parenteed6ff0358dc510e3d71bfe72aba4620de7d3418 (diff)
downloadpatches-f4eac09653ddebbe57e16824da42aad04af35632.tar
patches-f4eac09653ddebbe57e16824da42aad04af35632.tar.gz
gnu: Add r-siggenes.
* gnu/packages/bioconductor.scm (r-siggenes): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c188dacfbd..b29ae9d607 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2175,3 +2175,28 @@ the bridge between GEO and BioConductor.")
"This package provides tools for parsing Illumina's microarray output
files, including IDAT.")
(license license:gpl2)))
+
+(define-public r-siggenes
+ (package
+ (name "r-siggenes")
+ (version "1.56.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "siggenes" version))
+ (sha256
+ (base32
+ "0cjlb5r04x15xkhk00i3wvpx21kj0k29pn0mj3whwqk31zznnk1b"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-multtest" ,r-multtest)))
+ (home-page "https://bioconductor.org/packages/siggenes/")
+ (synopsis
+ "Multiple testing using SAM and Efron's empirical Bayes approaches")
+ (description
+ "This package provides tools for the identification of differentially
+expressed genes and estimation of the @dfn{False Discovery Rate} (FDR) using
+both the Significance Analysis of Microarrays (SAM) and the @dfn{Empirical
+Bayes Analyses of Microarrays} (EBAM).")
+ (license license:lgpl2.0+)))