summaryrefslogtreecommitdiff
path: root/gnu/packages/bdw-gc.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-20 12:13:44 -0400
committerMark H Weaver <mhw@netris.org>2014-08-20 12:16:13 -0400
commitc3114b756760ddb73054a4bc3d5eff0bfe47c4de (patch)
treec0d849ae59187a2c4ff9daf0e8f515ffa4161ce4 /gnu/packages/bdw-gc.scm
parent06a70dbec116efaf70ee29341921197496b06139 (diff)
downloadpatches-c3114b756760ddb73054a4bc3d5eff0bfe47c4de.tar
patches-c3114b756760ddb73054a4bc3d5eff0bfe47c4de.tar.gz
gnu: Add 'file' as a native-input on MIPS for some packages.
* gnu/packages/admin.scm (sudo): gnu/packages/gawk.scm (gawk): Add 'file' as a native input on MIPS. Remove earlier workaround on MIPS. * gnu/packages/libffi.scm (libffi): gnu/packages/bdw-gc.scm (libatomic-ops, libgc): Add 'file' as a native input on MIPS.
Diffstat (limited to 'gnu/packages/bdw-gc.scm')
-rw-r--r--gnu/packages/bdw-gc.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index df7cd1b489..e68ca50b5e 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -22,6 +22,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages file)
#:use-module (gnu packages pkg-config))
(define-public libgc-7.2
@@ -75,6 +76,12 @@ C or C++ programs, though that is not its primary goal.")
(base32
"1pdm0h1y7bgkczr8byg20r6bq15m5072cqm5pny4f9crc9gn3yh4"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(;; 'file' is needed by the pre-release libtool on MIPS.
+ ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+ (%current-system)))
+ `(("file" ,file))
+ '())))
(outputs '("out" "debug"))
(synopsis "Accessing hardware atomic memory update operations")
(description
@@ -99,7 +106,13 @@ lock-free code, experiment with thread programming paradigms, etc.")
"18mg28rr6kwr5clc65k4l4hkyy4kd16amx831sjf8q2lqkbhlck3"))))
;; New dependencies.
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ;; 'file' is needed by the pre-release libtool on MIPS.
+ ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+ (%current-system)))
+ `(("file" ,file))
+ '())))
(inputs `(("libatomic-ops" ,libatomic-ops)))
;; 'USE_LIBC_PRIVATES' is now the default.