summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 05:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:38:55 +0100
commit38e10e08b3b45f44e53f09b1ff90755e3f95c9eb (patch)
treebba841740479eb8985d329366f7ef26ed14746c3 /gnu/packages/bash.scm
parent3d871095f2aec355bc4ebea63e75f76dbc79a9be (diff)
downloadpatches-38e10e08b3b45f44e53f09b1ff90755e3f95c9eb.tar
patches-38e10e08b3b45f44e53f09b1ff90755e3f95c9eb.tar.gz
gnu: bash-tap: Don't use unstable tarball.
* gnu/packages/bash.scm (bash-tap)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index d3abeec6e6..bb2397fafa 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -31,6 +31,7 @@
#:use-module (gnu packages linux)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix gexp)
#:use-module (guix monads)
@@ -309,14 +310,15 @@ completion for many common commands.")
(package
(name "bash-tap")
(version "1.0.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/illusori/bash-tap/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0qs1qi38bl3ns4mpagcawv618dsk2q1lgrbddgvs0wl3ia12cyz5"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/illusori/bash-tap.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13zz9h6bhhnk3hiwhlpafrnf2isws249h3fz785dcgymk02arz9c"))))
;; There is no compilation process to use this package, however, the bash
;; scripts installed by this package start with "#!/bin/bash". To fix
;; these lines, we use the patch-shebangs of the GNU build system. The