summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-06-25 20:58:17 -0400
committerMark H Weaver <mhw@netris.org>2017-06-25 21:56:22 -0400
commitffc015bea26f24d862e7e877d907fbe1ab9a9967 (patch)
tree0386ba824424b7c64b9adf5845e1ba93e9fcf626 /gnu/packages/base.scm
parentafc9d8ec2b724b67f85b05011725bb636f209a1a (diff)
downloadpatches-ffc015bea26f24d862e7e877d907fbe1ab9a9967.tar
patches-ffc015bea26f24d862e7e877d907fbe1ab9a9967.tar.gz
gnu: glibc: Fix replacement on i686.
This is followup to 665d6a59161769e10b52ffcbcd5cd2db22f32681. Fixes <https://bugs.gnu.org/27489>. * gnu/packages/base.scm (glibc-2.25-patched, glibc-2.24, glibc-2.23) (glibc-2.22): Add glibc-vectorized-strcspn-guards.patch to patches. Move a comment where it belongs. * gnu/packages/patches/glibc-CVE-2017-1000366-pt2.patch: Swap with ... * gnu/packages/patches/glibc-CVE-2017-1000366-pt3.patch: ... this. * gnu/packages/patches/glibc-vectorized-strcspn-guards.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Fix formatting.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 2767909805..979d657957 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -902,9 +902,6 @@ GLIBC/HURD for a Hurd host"
(define-syntax glibc
(identifier-syntax (glibc-for-target)))
-;; Below are old libc versions, which we use mostly to build locale data in
-;; the old format (which the new libc cannot cope with.)
-
(define glibc-2.25-patched
(package
(inherit glibc)
@@ -914,10 +911,14 @@ GLIBC/HURD for a Hurd host"
(patches (search-patches "glibc-ldd-x86_64.patch"
"glibc-versioned-locpath.patch"
"glibc-o-largefile.patch"
+ "glibc-vectorized-strcspn-guards.patch"
"glibc-CVE-2017-1000366-pt1.patch"
"glibc-CVE-2017-1000366-pt2.patch"
"glibc-CVE-2017-1000366-pt3.patch"))))))
+;; Below are old libc versions, which we use mostly to build locale data in
+;; the old format (which the new libc cannot cope with.)
+
(define-public glibc-2.24
(package
(inherit glibc)
@@ -933,6 +934,7 @@ GLIBC/HURD for a Hurd host"
(patches (search-patches "glibc-ldd-x86_64.patch"
"glibc-versioned-locpath.patch"
"glibc-o-largefile.patch"
+ "glibc-vectorized-strcspn-guards.patch"
"glibc-CVE-2017-1000366-pt1.patch"
"glibc-CVE-2017-1000366-pt2.patch"
"glibc-CVE-2017-1000366-pt3.patch"))))))
@@ -952,6 +954,7 @@ GLIBC/HURD for a Hurd host"
(patches (search-patches "glibc-ldd-x86_64.patch"
"glibc-versioned-locpath.patch"
"glibc-o-largefile.patch"
+ "glibc-vectorized-strcspn-guards.patch"
"glibc-CVE-2017-1000366-pt1.patch"
"glibc-CVE-2017-1000366-pt2.patch"
"glibc-CVE-2017-1000366-pt3.patch"))))))
@@ -969,6 +972,7 @@ GLIBC/HURD for a Hurd host"
(base32
"0j49682pm2nh4qbdw35bas82p1pgfnz4d2l7iwfyzvrvj0318wzb"))
(patches (search-patches "glibc-ldd-x86_64.patch"
+ "glibc-vectorized-strcspn-guards.patch"
"glibc-CVE-2017-1000366-pt1.patch"
"glibc-CVE-2017-1000366-pt2.patch"
"glibc-CVE-2017-1000366-pt3.patch"))))