summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-24 22:04:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-24 22:04:29 +0200
commit2cce5fc59815f221f2671f91a7f44109f156367c (patch)
tree71fb18daeeae54bff72a1381dde974288a4efbc7 /gnu/packages/base.scm
parenta9c4f1ba51de9a0a38446437e80a77c46da0da5a (diff)
downloadpatches-2cce5fc59815f221f2671f91a7f44109f156367c.tar
patches-2cce5fc59815f221f2671f91a7f44109f156367c.tar.gz
gnu: glibc: Incorporate grafted changes.
* gnu/packages/base.scm (glibc/linux)[source](patches): Add 'glibc-CVE-2017-15670-15671.patch'. (glibc/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 16c6a15a58..b7d60de589 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -509,7 +509,6 @@ store.")
(package
(name "glibc")
(version "2.25")
- (replacement glibc/fixed)
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-"
@@ -530,6 +529,7 @@ store.")
"glibc-o-largefile.patch"
"glibc-memchr-overflow-i686.patch"
"glibc-vectorized-strcspn-guards.patch"
+ "glibc-CVE-2017-15670-15671.patch"
"glibc-CVE-2017-1000366-pt1.patch"
"glibc-CVE-2017-1000366-pt2.patch"
"glibc-CVE-2017-1000366-pt3.patch"))))
@@ -813,15 +813,6 @@ GLIBC/HURD for a Hurd host"
(define-syntax glibc
(identifier-syntax (glibc-for-target)))
-(define glibc/fixed
- (package
- (inherit glibc)
- (source (origin
- (inherit (package-source glibc))
- (patches (append
- (origin-patches (package-source glibc))
- (search-patches "glibc-CVE-2017-15670-15671.patch")))))))
-
;; Below are old libc versions, which we use mostly to build locale data in
;; the old format (which the new libc cannot cope with.)