summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-24 16:37:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:23:36 +0200
commit8c8ded2cc9201e69e87999bb40ef09c6c868deb8 (patch)
treeaf8b38bf0c12c9f9b322fedffc17b9163b46f3d2 /gnu/packages/base.scm
parenta8dcf6cec7c5ded4bd0967f00b9b502d7d66e5ef (diff)
downloadpatches-8c8ded2cc9201e69e87999bb40ef09c6c868deb8.tar
patches-8c8ded2cc9201e69e87999bb40ef09c6c868deb8.tar.gz
gnu: grep: Work around test failure with glibc 2.28.
* gnu/packages/base.scm (grep)[arguments]: Add phase 'disable-failing-tests'.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 114413bafc..1c652bcce4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -102,6 +102,15 @@ command-line arguments, multiple languages, and so on.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'check 'disable-failing-tests
+ (lambda _
+ ;; These tests are expected to fail due to a glibc bug which has
+ ;; been fixed in 2.28, so they are unexpectedly passing. They
+ ;; should be fixed for grep versions > 3.1.
+ (substitute* "tests/Makefile.in"
+ (("^[[:blank:]]+backref-alt[[:blank:]]+\\\\") "\\")
+ (("^[[:blank:]]+triple-backref[[:blank:]]+\\\\") "\\"))
+ #t))
(add-after 'install 'fix-egrep-and-fgrep
;; Patch 'egrep' and 'fgrep' to execute 'grep' via its
;; absolute file name instead of searching for it in $PATH.