summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-16 14:53:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-16 15:32:22 +0100
commitff19532fd545fd1b039d471155c2430c8efc1b27 (patch)
tree431497a0a84dff3ea9031a3ac3c0d3179b3db12e /gnu/packages/base.scm
parent8809a15389dfd8ae226af04b102facc8874947f7 (diff)
downloadpatches-ff19532fd545fd1b039d471155c2430c8efc1b27.tar
patches-ff19532fd545fd1b039d471155c2430c8efc1b27.tar.gz
gnu: binutils: Update to 2.30.
* gnu/packages/patches/binutils-ld-new-dtags.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/base.scm (binutils): Update to 2.30. [source](patches): Remove obsolete patch. [arguments]: Add "--enable-new-dtags" in #:configure-flags.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 892a41601b..783f2cabe7 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -415,16 +415,15 @@ change. GNU make offers many powerful extensions over the standard utility.")
(define-public binutils
(package
(name "binutils")
- (version "2.28.1")
+ (version "2.30")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/binutils/binutils-"
version ".tar.bz2"))
(sha256
(base32
- "1sj234nd05cdgga1r36zalvvdkvpfbr12g5mir2n8i1dwsdrj939"))
- (patches (search-patches "binutils-ld-new-dtags.patch"
- "binutils-loongson-workaround.patch"))))
+ "028cklfqaab24glva1ks2aqa1zxa6w6xmc8q34zs1sb7h22dxspg"))
+ (patches (search-patches "binutils-loongson-workaround.patch"))))
(build-system gnu-build-system)
;; TODO: Add dependency on zlib + those for Gold.
@@ -433,6 +432,12 @@ change. GNU make offers many powerful extensions over the standard utility.")
;; on GCC when bootstrapping.
"LDFLAGS=-static-libgcc"
+ ;; Turn on --enable-new-dtags by default to make the
+ ;; linker set RUNPATH instead of RPATH on binaries.
+ ;; This is important because RUNPATH can be overriden
+ ;; using LD_LIBRARY_PATH at runtime.
+ "--enable-new-dtags"
+
;; Don't search under /usr/lib & co.
"--with-lib-path=/no-ld-lib-path"