summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-18 13:46:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-19 00:52:22 +0200
commit6c4709889c665f194822677dc7a1fcd513e46708 (patch)
treee9939284a46f1ed42c3632b37bf75b03e9a3da48 /gnu/packages/base.scm
parent45719c1dfb7bdce3c91086e5bed26643dccf8191 (diff)
downloadpatches-6c4709889c665f194822677dc7a1fcd513e46708.tar
patches-6c4709889c665f194822677dc7a1fcd513e46708.tar.gz
gnu: binutils: Update to 2.31.1.
* gnu/packages/base.scm (binutils): Update to 2.31.1. (binutils/fixed): Remove variable * gnu/packages/linux.scm (make-linux-libre): Remove AArch64 workaround. * gnu/packages/patches/binutils-aarch64-symbol-relocation.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fef6002b3c..c95ab379af 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -435,14 +435,14 @@ change. GNU make offers many powerful extensions over the standard utility.")
(define-public binutils
(package
(name "binutils")
- (version "2.30")
+ (version "2.31.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/binutils/binutils-"
version ".tar.bz2"))
(sha256
(base32
- "028cklfqaab24glva1ks2aqa1zxa6w6xmc8q34zs1sb7h22dxspg"))
+ "1l34hn1zkmhr1wcrgf0d4z7r3najxnw3cx2y2fk7v55zjlk3ik7z"))
(patches (search-patches "binutils-loongson-workaround.patch"))))
(build-system gnu-build-system)
@@ -480,17 +480,6 @@ included.")
(license gpl3+)
(home-page "https://www.gnu.org/software/binutils/")))
-(define-public binutils/fixed
- ;; TODO: Incorporate this in binutils during the next rebuild cycle.
- (hidden-package
- (package
- (inherit binutils)
- (source (origin
- (inherit (package-source binutils))
- (patches (append (origin-patches (package-source binutils))
- (search-patches
- "binutils-aarch64-symbol-relocation.patch"))))))))
-
(define* (make-ld-wrapper name #:key
(target (const #f))
binutils