summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-04 11:56:51 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-04 11:56:51 +0200
commit62ea8865257a156625554dfd1e0418dc220e3c20 (patch)
treeecde249ecb5d0c1891659ae6f55e0caf01d3587f /gnu/packages/base.scm
parent92226a470ddc980e54863632e5b179bf40444bd7 (diff)
downloadpatches-62ea8865257a156625554dfd1e0418dc220e3c20.tar
patches-62ea8865257a156625554dfd1e0418dc220e3c20.tar.gz
gnu: coreutils: Drop dependency on libcap when cross-compiling.
* gnu/packages/base.scm (coreutils)[inputs]: Drop LIBCAP when (%current-target-system) is true.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f043f8233c..00571a8318 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -249,7 +249,12 @@ used to apply commands with arbitrarily long arguments.")
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp) ;bignums in 'expr', yay!
- ("libcap" ,libcap))) ;capability support is 'ls','dir', 'vdir'
+
+ ;; Drop the dependency on libcap when cross-compiling since it's
+ ;; not quite cross-compilable.
+ ,@(if (%current-target-system)
+ '()
+ `(("libcap" ,libcap))))) ;capability support is 'ls', etc.
(native-inputs
;; Perl is needed to run tests in native builds, and to run the bundled
;; copy of help2man. However, don't pass it when cross-compiling since