summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-20 10:56:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-20 10:57:18 +0200
commite74796442095370259df714c7700b8412459e804 (patch)
tree1ef64055883b135c6a3bd13a5146fb106a0b15ca /gnu/packages/base.scm
parent864738baaa7bb75c08647ccfc684736479e67f7f (diff)
downloadpatches-e74796442095370259df714c7700b8412459e804.tar
patches-e74796442095370259df714c7700b8412459e804.tar.gz
gnu: coreutils: Don't run tests in parallel.
* gnu/packages/base.scm (coreutils)[arguments]: Add '#:parallel-tests? #f' to address a race contition in the test suite.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 8dbec90a67..8be9c88abb 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -313,6 +313,7 @@ used to apply commands with arbitrarily long arguments.")
(outputs '("out" "debug"))
(arguments
`(#:parallel-build? #f ; help2man may be called too early
+ #:parallel-tests? #f ; race condition fixed after 8.26
#:phases (alist-cons-before
'build 'patch-shell-references
(lambda* (#:key inputs #:allow-other-keys)