summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-07 21:33:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-08 00:59:06 +0300
commit656a5ba0d54739cf67d104b4fcb1126813f03f4e (patch)
tree03e5865ce4a015cae7c1632858136da3c53e9b04 /gnu/packages/base.scm
parentb01981a9e280b1ea051d332ea5bdeab2f72fbb43 (diff)
downloadpatches-656a5ba0d54739cf67d104b4fcb1126813f03f4e.tar
patches-656a5ba0d54739cf67d104b4fcb1126813f03f4e.tar.gz
gnu: coreutils: Update build phase.
* gnu/packages/base.scm (coreutils)[arguments]: Use 'modify-phases' syntax. Substitute with 'which sh'.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 20f5ab7de6..be19c5f76f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -320,21 +320,18 @@ used to apply commands with arbitrarily long arguments.")
(outputs '("out" "debug"))
(arguments
`(#:parallel-build? #f ; help2man may be called too early
- #:phases (alist-cons-before
- 'build 'patch-shell-references
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
- ;; 'split' uses either $SHELL or /bin/sh. Set $SHELL so
- ;; that tests pass, since /bin/sh isn't in the chroot.
- (setenv "SHELL" (which "sh"))
-
- (substitute* (find-files "gnulib-tests" "\\.c$")
- (("/bin/sh")
- (format #f "~a/bin/sh" bash)))
- (substitute* (find-files "tests" "\\.sh$")
- (("#!/bin/sh")
- (format #f "#!~a/bin/sh" bash)))))
- %standard-phases)))
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'patch-shell-references
+ (lambda _
+ ;; 'split' uses either $SHELL or /bin/sh. Set $SHELL so
+ ;; that tests pass, since /bin/sh isn't in the chroot.
+ (setenv "SHELL" (which "sh"))
+
+ (substitute* (find-files "gnulib-tests" "\\.c$")
+ (("/bin/sh") (which "sh")))
+ (substitute* (find-files "tests" "\\.sh$")
+ (("#!/bin/sh") (which "sh")))
+ #t)))))
(synopsis "Core GNU utilities (file, text, shell)")
(description
"GNU Coreutils includes all of the basic command-line tools that are