summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-10-28 11:16:46 +0900
committerMathieu Othacehe <m.othacehe@gmail.com>2018-11-07 18:47:07 +0900
commit1b9fb043d9c2fbd047ab17209ca4a3de5293edee (patch)
tree11ec1ca89fdeaad0de0a25218b37fb55554576f9 /gnu/packages/base.scm
parenta036e3c9ba8c303f06e221f14285d265c7b0b4fc (diff)
downloadpatches-1b9fb043d9c2fbd047ab17209ca4a3de5293edee.tar
patches-1b9fb043d9c2fbd047ab17209ca4a3de5293edee.tar.gz
gnu: glibc: Export supported locales.
Debian and Archlinux (at least) force the installation of the localedata/SUPPORTED file of the glibc. This file lists all the supported locales of the glibc. * gnu/packages/patches/glibc-supported-locales.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc/linux): Add the previous patch, (glibc-2.28): ditto.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 3a1186673e..a6ece07ad9 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -604,7 +604,8 @@ store.")
"glibc-hidden-visibility-ldconfig.patch"
"glibc-versioned-locpath.patch"
"glibc-allow-kernel-2.6.32.patch"
- "glibc-reinstate-prlimit64-fallback.patch"))))
+ "glibc-reinstate-prlimit64-fallback.patch"
+ "glibc-supported-locales.patch"))))
(build-system gnu-build-system)
;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc
@@ -901,7 +902,8 @@ GLIBC/HURD for a Hurd host"
"glibc-hidden-visibility-ldconfig.patch"
"glibc-versioned-locpath.patch"
"glibc-allow-kernel-2.6.32.patch"
- "glibc-reinstate-prlimit64-fallback.patch"))))))
+ "glibc-reinstate-prlimit64-fallback.patch"
+ "glibc-supported-locales.patch"))))))
(define-public glibc-2.26
(package