summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-06 18:08:29 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-06 18:08:29 +0200
commitc8ebc82187d83e845a201bbe45d837c97f9c64b1 (patch)
tree1364b1ccd33c16f4fc97428ea6ab47a205f029b0 /gnu/packages/base.scm
parent3a4ebc11240761901de75da3ffebbace5a70cf6c (diff)
downloadpatches-c8ebc82187d83e845a201bbe45d837c97f9c64b1.tar
patches-c8ebc82187d83e845a201bbe45d837c97f9c64b1.tar.gz
gnu: gcc: Add Texinfo to the native inputs.
* gnu/packages/gcc.scm (gcc-4.7): Add `native-inputs' field. (gcc-4.8): Remove outdated comment. * gnu/packages/base.scm (gcc-boot0): Add `native-inputs' field.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7ca7ec74c6..a5c6a70603 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -756,7 +756,11 @@ identifier SYSTEM."
;; Call it differently so that the builder can check whether
;; the "libc" input is #f.
("libc-native" ,@(assoc-ref %boot0-inputs "libc"))
- ,@(alist-delete "libc" %boot0-inputs))))))
+ ,@(alist-delete "libc" %boot0-inputs)))
+
+ ;; No need for Texinfo at this stage.
+ (native-inputs (alist-delete "texinfo"
+ (package-native-inputs gcc-4.7))))))
(define linux-libre-headers-boot0
(package-with-bootstrap-guile