summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-14 16:26:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-14 16:28:22 +0100
commit441010a2d1f77b15f9becfac622e9b1d76b7b1fd (patch)
treeb271e218cdcba487fafc11237ee4fb6c5b1778e2 /gnu/packages/base.scm
parent48b97be90bbbdf3108e70d9e23bc8f296d4451b5 (diff)
downloadpatches-441010a2d1f77b15f9becfac622e9b1d76b7b1fd.tar
patches-441010a2d1f77b15f9becfac622e9b1d76b7b1fd.tar.gz
Revert "gnu: Use patched static bash in glibc replacement."
This reverts commit 42958b5e0feff1000ba17a353bb58fdf45f20716.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm27
1 files changed, 1 insertions, 26 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 56f79f5801..e91f7d43ef 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -841,7 +841,7 @@ GLIBC/HURD for a Hurd host"
;; Below are old libc versions, which we use mostly to build locale data in
;; the old format (which the new libc cannot cope with.)
-(define glibc-2.26-patched-boot
+(define glibc-2.26-patched
(package
(inherit glibc)
(source (origin
@@ -849,31 +849,6 @@ GLIBC/HURD for a Hurd host"
(patches (cons (search-patch "glibc-allow-kernel-2.6.32.patch")
(origin-patches (package-source glibc))))))))
-(define patched-static-bash
- (package
- (inherit static-bash)
- (arguments
- (substitute-keyword-arguments (package-arguments static-bash)
- ((#:configure-flags flags '())
- ;; Add a '-L' flag so that the pseudo-cross-ld of
- ;; BINUTILS-BOOT0 can find libc.a.
- `(append ,flags
- (list (string-append "LDFLAGS=-static -L"
- (assoc-ref %build-inputs
- "libc-patched:static")
- "/lib"))))))
- (native-inputs
- `(("libc-patched" ,glibc-2.26-patched-boot)
- ("libc-patched:static" ,glibc-2.26-patched-boot "static")))))
-
-(define glibc-2.26-patched
- (package
- (inherit glibc-2.26-patched-boot)
- (inputs `(("static-bash" ,patched-static-bash)
- ,@(alist-delete
- "static-bash"
- (package-inputs glibc-2.26-patched-boot))))))
-
(define-public glibc-2.25
(package
(inherit glibc)