summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-10 00:42:22 -0400
committerMark H Weaver <mhw@netris.org>2018-04-10 00:42:22 -0400
commitf89aa1521af69b0e1a1350c2380579788b0f8945 (patch)
tree5009cca687ac669ef846920877cbfb6fffdd9893 /gnu/packages/backup.scm
parent169c658f7f286efae397fa3eda55b1c56fa92a01 (diff)
parent60e1de6d95bd32b4996c199708541781b8f828fd (diff)
downloadpatches-f89aa1521af69b0e1a1350c2380579788b0f8945.tar
patches-f89aa1521af69b0e1a1350c2380579788b0f8945.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 408a4a5f41..8d988a08a2 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -471,13 +471,13 @@ detection, and lossless compression.")
(define-public borg
(package
(name "borg")
- (version "1.1.4")
+ (version "1.1.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(sha256
- (base32 "1cicqwh85wfp65y00qaq6q4i4jcyy9b66qz5gpl80qc880wab912"))
+ (base32 "0gbdnq7ks46diz6y2pf6wpwkb9hy6hp3immi7jg3h7w72b3ycmj3"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -510,6 +510,17 @@ detection, and lossless compression.")
;; HOME=/homeless-shelter.
(setenv "HOME" "/tmp")
#t)))
+ ;; Later versions of msgpack were disallowed to some warnings and lack
+ ;; of support for Python versions that we don't support anyways. So,
+ ;; it's okay to to keep using more recents versions of msgpack for
+ ;; Borg. Also see the note about msgpack in the list of inputs.
+ ;; https://github.com/borgbackup/borg/issues/3517#issuecomment-357221978
+ (add-before 'build 'adjust-msgpack-dependency
+ (lambda _
+ (substitute* "setup.py"
+ (("msgpack-python>=0.4.6,<0.5.0")
+ "msgpack-python>=0.4.6"))
+ #t))
;; The tests need to be run after Borg is installed.
(delete 'check)
(add-after 'install 'check