summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-13 02:23:38 -0400
committerLeo Famulari <leo@famulari.name>2016-05-13 02:23:38 -0400
commit4fa05a81983d4aa33837e1c01457442be7b58aad (patch)
tree12a99e3d3f978de597d442437ec557f9c04d2e22 /gnu/packages/backup.scm
parenteb74eb4199db3faac654114257996f244ec308f5 (diff)
downloadpatches-4fa05a81983d4aa33837e1c01457442be7b58aad.tar
patches-4fa05a81983d4aa33837e1c01457442be7b58aad.tar.gz
gnu: libarchive: Update to 3.2.0.
* gnu/packages/patches/libarchive-CVE-2013-0211.patch, gnu/packages/patches/libarchive-CVE-2016-1541.patch, gnu/packages/patches/libarchive-bsdtar-test.patch, gnu/packages/patches/libarchive-fix-lzo-test-case.patch, gnu/packages/patches/libarchive-mtree-filename-length-fix.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/backup.scm (libarchive): Update to 3.2.0. [source]: Remove deleted patches. [replacement]: Remove. (libarchive/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 917bee78d9..05423f1401 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -136,8 +136,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(define-public libarchive
(package
(name "libarchive")
- (replacement libarchive/fixed)
- (version "3.1.2")
+ (version "3.2.0")
(source
(origin
(method url-fetch)
@@ -145,12 +144,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
version ".tar.gz"))
(sha256
(base32
- "0pixqnrcf35dnqgv0lp7qlcw7k13620qkhgxr288v7p4iz6ym1zb"))
- (patches
- (search-patches "libarchive-mtree-filename-length-fix.patch"
- "libarchive-fix-lzo-test-case.patch"
- "libarchive-CVE-2013-0211.patch"
- "libarchive-bsdtar-test.patch"))))
+ "11xabdpmvdmcdkidigmqh4ymhra95lr7ipcys4hdq0gzf7ylbkkv"))))
(build-system gnu-build-system)
;; TODO: Add -L/path/to/nettle in libarchive.pc.
(inputs
@@ -194,14 +188,6 @@ archive. In particular, note that there is currently no built-in support for
random access nor for in-place modification.")
(license license:bsd-2)))
-(define libarchive/fixed
- (package
- (inherit libarchive)
- (source (origin
- (inherit (package-source libarchive))
- (patches (cons (search-patch "libarchive-CVE-2016-1541.patch")
- (origin-patches (package-source libarchive))))))))
-
(define-public rdup
(package
(name "rdup")