summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-30 01:09:08 -0500
committerLeo Famulari <leo@famulari.name>2016-11-30 01:52:16 -0500
commit1d60f7c2b38733b031519a48771c44d20acb785d (patch)
tree85143311b550c1c88472bb1cb1526de723af6838 /gnu/packages/backup.scm
parent663d5b5330e05fdf2c1b55d699955f3fd9668c24 (diff)
downloadpatches-1d60f7c2b38733b031519a48771c44d20acb785d.tar
patches-1d60f7c2b38733b031519a48771c44d20acb785d.tar.gz
gnu: borg: Fix the test suite.
* gnu/packages/backup.scm (borg)[arguments]: Use add-installed-pythonpath and disable tests related to FUSE.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 94b2e82242..a503b06603 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -435,7 +435,9 @@ detection, and lossless compression.")
;; The tests need to be run after Borg is installed.
(delete 'check)
(add-after 'install 'check
- (lambda _
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed package available for the test suite.
+ (add-installed-pythonpath inputs outputs)
(zero?
(system* "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
(string-append
@@ -448,7 +450,13 @@ detection, and lossless compression.")
"and not test_default_acl "
"and not test_non_ascii_acl "
;; This test needs the unpackaged pytest-benchmark.
- "and not benchmark")))))
+ "and not benchmark "
+ ;; These tests assume the kernel supports FUSE. They
+ ;; were skipped using the "old" Python build system,
+ ;; before commit
+ ;; 7db40bce58e149ecb541d295e01cfbfe953d39a3.
+ "and not test_fuse "
+ "and not test_fuse_allow_damaged_files")))))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))