summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-09-23 23:36:48 -0400
committerLeo Famulari <leo@famulari.name>2016-09-28 13:07:06 -0400
commitb2fe918302de7a1e978cf820a55beb110362ecce (patch)
treed5933985ae732e782470f1c2098788c5be878b12 /gnu/packages/backup.scm
parent415ee287faca319f53ba908843a30750afcfc451 (diff)
downloadpatches-b2fe918302de7a1e978cf820a55beb110362ecce.tar
patches-b2fe918302de7a1e978cf820a55beb110362ecce.tar.gz
gnu: attic: Superseded by borg.
* gnu/packages/backup.scm (attic)[properties]: New field.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm85
1 files changed, 43 insertions, 42 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index e77c4f20a9..c6f1321d77 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -358,48 +358,6 @@ to a remote location, and only the differences will be transmitted. Finally,
rdiff-backup is easy to use and settings have sensible defaults.")
(license license:gpl2+)))
-(define-public attic
- (package
- (name "attic")
- (version "0.16")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/A/Attic/Attic-"
- version ".tar.gz"))
- (sha256
- (base32
- "0b5skd36r4c0915lwpkqg5hxm49gls9pprs1b7hc40910wlcsl36"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before
- 'build 'set-openssl-prefix
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "ATTIC_OPENSSL_PREFIX" (assoc-ref inputs "openssl"))
- #t)))))
- (inputs
- `(("acl" ,acl)
- ("openssl" ,openssl)
- ("python-msgpack" ,python-msgpack)
-
- ;; Attic is probably incompatible with llfuse > 0.41.
- ;; These links are to discussions of llfuse compatibility from
- ;; the borg project. Borg is a recent fork of attic, and attic
- ;; has not been updated since the fork, so it's likely that
- ;; llfuse compatibility requirements are still the same.
- ;; https://github.com/borgbackup/borg/issues/642
- ;; https://github.com/borgbackup/borg/issues/643
- ("python-llfuse" ,python-llfuse-0.41)))
- (synopsis "Deduplicating backup program")
- (description "Attic is a deduplicating backup program. The main goal of
-Attic is to provide an efficient and secure way to backup data. The data
-deduplication technique used makes Attic suitable for daily backups since only
-changes are stored.")
- (home-page "https://attic-backup.org/")
- (license license:bsd-3)))
-
(define-public libchop
(package
(name "libchop")
@@ -497,3 +455,46 @@ stored. The authenticated encryption technique makes it suitable for backups
to not fully trusted targets. Borg is a fork of Attic.")
(home-page "https://borgbackup.github.io/borgbackup/")
(license license:bsd-3)))
+
+(define-public attic
+ (package
+ (name "attic")
+ (version "0.16")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/A/Attic/Attic-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0b5skd36r4c0915lwpkqg5hxm49gls9pprs1b7hc40910wlcsl36"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'build 'set-openssl-prefix
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "ATTIC_OPENSSL_PREFIX" (assoc-ref inputs "openssl"))
+ #t)))))
+ (inputs
+ `(("acl" ,acl)
+ ("openssl" ,openssl)
+ ("python-msgpack" ,python-msgpack)
+
+ ;; Attic is probably incompatible with llfuse > 0.41.
+ ;; These links are to discussions of llfuse compatibility from
+ ;; the borg project. Borg is a recent fork of attic, and attic
+ ;; has not been updated since the fork, so it's likely that
+ ;; llfuse compatibility requirements are still the same.
+ ;; https://github.com/borgbackup/borg/issues/642
+ ;; https://github.com/borgbackup/borg/issues/643
+ ("python-llfuse" ,python-llfuse-0.41)))
+ (synopsis "Deduplicating backup program")
+ (description "Attic is a deduplicating backup program. The main goal of
+Attic is to provide an efficient and secure way to backup data. The data
+deduplication technique used makes Attic suitable for daily backups since only
+changes are stored.")
+ (home-page "https://attic-backup.org/")
+ (license license:bsd-3)
+ (properties `((superseded . ,borg)))))