summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-28 23:20:02 -0500
committerLeo Famulari <leo@famulari.name>2018-02-28 23:43:23 -0500
commitacb59d99dbb8779ecf41cdbba45d2ce8ba88f5ed (patch)
tree03fbc6530db927638ef7094ac303c64f001762df /gnu/packages/backup.scm
parent2adfe819f08ab19cfee7ae381b960de4c110441e (diff)
downloadpatches-acb59d99dbb8779ecf41cdbba45d2ce8ba88f5ed.tar
patches-acb59d99dbb8779ecf41cdbba45d2ce8ba88f5ed.tar.gz
gnu: Fix Borg crashes with Python msgpack > 0.5
The Python msgpack library changed its name, but borg (and possibly other packages) still uses the old name. Fixes <https://bugs.gnu.org/30662>. * gnu/packages/python.scm (python-msgpack-transitional): New variable. * gnu/packages/backup.scm (borg)[inputs]: Use it.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 48d4b08af6..2fafa2c4a6 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -547,7 +547,10 @@ detection, and lossless compression.")
("lz4" ,lz4)
("openssl" ,openssl)
("python-llfuse" ,python-llfuse)
- ("python-msgpack" ,python-msgpack)
+ ;; The Python msgpack library changed its name so Borg requires this
+ ;; transitional package for now:
+ ;; <https://bugs.gnu.org/30662>
+ ("python-msgpack" ,python-msgpack-transitional)
("zstd" ,zstd)))
(synopsis "Deduplicated, encrypted, authenticated and compressed backups")
(description "Borg is a deduplicating backup program. Optionally, it