summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-13 00:34:16 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-13 00:34:16 +0100
commit2cab1dd58b9a8fb4db8f46a0b00e1358fc0de21b (patch)
treeb0f12de9371ebbd806214df841cf3a1c116d5431 /gnu/packages/audio.scm
parent15abcabe4e1d34416714eae66dba32ff96d05a6f (diff)
parentde7da4e5d14a1acace1a89d9c520d336eecc7e45 (diff)
downloadpatches-2cab1dd58b9a8fb4db8f46a0b00e1358fc0de21b.tar
patches-2cab1dd58b9a8fb4db8f46a0b00e1358fc0de21b.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 1159e8dfb7..7d2e2d2a4b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -462,7 +462,7 @@ emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
("liblo" ,liblo)
("ladspa" ,ladspa)
("jack" ,jack-1)
- ("gettext" ,gnu-gettext)))
+ ("gettext" ,gettext-minimal)))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
@@ -1043,7 +1043,7 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
`(("gperf" ,gperf)
("faust" ,faust)
("intltool" ,intltool)
- ("gettext" ,gnu-gettext)
+ ("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(native-search-paths
(list (search-path-specification
@@ -2213,7 +2213,15 @@ conversion. It may be used, for example, to resample PCM-encoded audio.")
(uri (string-append "mirror://sourceforge/twolame/twolame/" version
"/twolame-" version ".tar.gz"))
(sha256
- (base32 "0ahiqqng5pidwhj1wzph4vxxgxxgcfa3gl0gywipzx2ii7s35wwq"))))
+ (base32 "0ahiqqng5pidwhj1wzph4vxxgxxgcfa3gl0gywipzx2ii7s35wwq"))
+ (modules '((guix build utils)))
+ ;; The tests break with Perl 5.24:
+ ;; https://github.com/njh/twolame/issues/21
+ ;; TODO: Remove this snippet when upgrading twolame.
+ (snippet
+ '(begin
+ (substitute* "tests/test.pl" (("\\(@_\\)") "($_[0])"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("libsndfile" ,libsndfile)))