summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2019-11-08 23:56:58 +0000
committerMarius Bakke <mbakke@fastmail.com>2019-11-20 00:16:51 +0100
commitcaa1f6a8ae6d60e2a79cd151e86fb1270893e670 (patch)
tree47fa246af45248657ab4b266e2446cdece62dc82 /gnu/packages/audio.scm
parent711e8bf75fdacc8218b3957bbd7cb367da6392b5 (diff)
downloadpatches-caa1f6a8ae6d60e2a79cd151e86fb1270893e670.tar
patches-caa1f6a8ae6d60e2a79cd151e86fb1270893e670.tar.gz
gnu: Add carla.
* gnu/packages/audio.scm (carla): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d59b4eb87e..e10af39950 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3811,3 +3811,59 @@ therefore satisfying any requirements they may have to be self contained,
as is the case with audio plugins.")
(home-page "https://gitlab.com/geontime/redkite")
(license license:gpl3+)))
+
+(define-public carla
+ (package
+ (name "carla")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/falkTX/Carla.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fqgncqlr86n38yy7pa118mswfacmfczj7w9xx6c6k0jav3wk29k"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable-and-show-features
+ (lambda _
+ (setenv "CC" "gcc")
+ (invoke "make" "features")))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("ffmpeg" ,ffmpeg)
+ ("fluidsynth" ,fluidsynth)
+ ("file" ,file)
+ ("liblo" ,liblo)
+ ("libsndfile" ,libsndfile)
+ ("gtk+" ,gtk+)
+ ("python-pyliblo" ,python-pyliblo)
+ ("python-pyqt" ,python-pyqt)
+ ("python-rdflib" ,python-rdflib)
+ ;; python-pyqt shows the following error without python-wrapper:
+ ;; Error while finding module specification for 'PyQt5.uic.pyuic'
+ ;; (ModuleNotFoundError: No module named 'PyQt5')
+ ("python-wrapper" ,python-wrapper)
+ ("libx11" ,libx11)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://kx.studio/Applications:Carla")
+ (synopsis "Audio plugin host")
+ (description "Carla is a modular audio plugin host, with features like
+transport control, automation of parameters via MIDI CC and remote control
+over OSC. Carla currently supports LADSPA (including LRDF), DSSI, LV2, VST2,
+and VST3 plugin formats, plus SF2 and SFZ file support. It uses JACK as the
+default and preferred audio driver but also supports native drivers like ALSA.")
+ (license license:gpl2+)))