summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-03-01 10:04:14 -0500
committerDavid Thompson <dthompson2@worcester.edu>2016-03-14 13:33:01 -0400
commit680b54c5ce4fe63f40ba99100eaa32b0b7d77769 (patch)
treea67764662dc4542496a7323c488386e0fbb2ceb9 /gnu/packages/audio.scm
parent1e3fbf3c6d65a1a92d0e1477f296680d877bd63b (diff)
downloadpatches-680b54c5ce4fe63f40ba99100eaa32b0b7d77769.tar
patches-680b54c5ce4fe63f40ba99100eaa32b0b7d77769.tar.gz
gnu: Add dcadec.
* gnu/packages/audio.scm (dcadec): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 10c2632867..7040e7958c 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2073,3 +2073,38 @@ module to handle that particular file type.")
(home-page "http://etree.org/shnutils/shntool/")
;; 'install-sh' bears the x11 license
(license (list license:gpl2+ license:x11))))
+
+(define-public dcadec
+ (package
+ (name "dcadec")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/foo86/dcadec/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0i0dpypgqkhhi4v1fmsp2way6w9kbcix3c7q79pmg39yvrzj17gd"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; Test files are missing: https://github.com/foo86/dcadec/issues/53
+ '(#:tests? #f
+ #:make-flags
+ (list "CC=gcc"
+ ;; Build shared library.
+ "CONFIG_SHARED=1"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ ;; Set proper runpath.
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ ;; No configure script, just a hand-written Makefile.
+ (delete 'configure))))
+ (synopsis "DTS Coherent Acoustics decoder")
+ (description "Dcadec is a DTS Coherent Acoustics surround sound decoder
+with support for HD extensions.")
+ (home-page "https://github.com/foo86/dcadec")
+ (license license:lgpl2.1+)))