summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-05 19:52:26 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-09 22:57:43 +0100
commit55b596c3f5bfde273377e019b5fcf56c8049881f (patch)
treeb903f77b8edfa5a19d4c9dbade2832ef0ccf52be /gnu/packages/audio.scm
parentf2fac35953fa14606d426a1bc42b0a0a238926a6 (diff)
downloadpatches-55b596c3f5bfde273377e019b5fcf56c8049881f.tar
patches-55b596c3f5bfde273377e019b5fcf56c8049881f.tar.gz
gnu: Add rsound.
* gnu/packages/audio.scm (rsound): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e9e924a836..e44db11199 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1105,6 +1105,46 @@ to record and/or play sound using a callback function or a blocking read/write
interface.")
(license license:expat)))
+(define-public rsound
+ (package
+ (name "rsound")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Themaister/RSound/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1wzs40c0k5zpkmm5ffl6c17xmr399sxli7ys0fbb9ib0fd334knx"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-2)
+ ("ao" ,ao)
+ ("libsamplerate" ,libsamplerate)
+ ("openal" ,openal)
+ ("portaudio" ,portaudio)
+ ("pulseaudio" ,pulseaudio)))
+ (arguments
+ '(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "CC" "gcc")
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" (assoc-ref outputs "out")))))
+ %standard-phases)
+ ;; No 'check' target.
+ #:tests? #f))
+ (home-page "http://themaister.net/rsound.html")
+ (synopsis "Networked audio system")
+ (description
+ "RSound allows you to send audio from an application and transfer it
+directly to a different computer on your LAN network. It is an audio daemon
+with a much different focus than most other audio daemons.")
+ (license license:gpl3+)))
+
(define-public zita-alsa-pcmi
(package
(name "zita-alsa-pcmi")