summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-24 22:18:07 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-24 22:18:07 +0200
commit1007b6bf0bef3f662f65ffdd0d4383179dd07355 (patch)
tree4a9b2a4baa2d82434e12fe4aacc8f28e3266793e /gnu/packages/audio.scm
parent12cd4dd3a9052491e3912ffeecbe8854ea9b971a (diff)
parenta7a4fd9a7cd02e4897e7b2156bd9ecc7e72e9818 (diff)
downloadpatches-1007b6bf0bef3f662f65ffdd0d4383179dd07355.tar
patches-1007b6bf0bef3f662f65ffdd0d4383179dd07355.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index cbf06250d0..a35ef278ee 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -60,6 +60,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages zip)
#:use-module (srfi srfi-1))
@@ -1739,6 +1740,39 @@ directly to a different computer on your LAN network. It is an audio daemon
with a much different focus than most other audio daemons.")
(license license:gpl3+)))
+(define-public xjackfreak
+ (package
+ (name "xjackfreak")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/johnhldavis/xjackfreak/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xj6gpxfnw9jbdgwgm0x23xgfvj2kwmwb1nk0drw8lxgcchkq7d9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "docdir=" (assoc-ref %outputs "out")
+ "/share/doc/xjackfreak"))))
+ (inputs
+ `(("jack" ,jack-1)
+ ("libx11" ,libx11)
+ ("libxt" ,libxt)
+ ("libxext" ,libxext)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/johnhldavis/xjackfreak")
+ (synopsis "JACK audio frequency analyzer and display")
+ (description
+ "XJackFreak is an audio analysis and equalizing tool for the Jack Audio
+Connection Kit. It can display the FFT of any input, modify it and output the
+result.")
+ (license license:gpl3+)))
+
(define-public zita-convolver
(package
(name "zita-convolver")