summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-11-15 09:31:11 +0000
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 14:29:57 +0100
commitbcdf11d6ffd8cc55653ff0257f7a832aaa385c60 (patch)
tree0dfb4c76bd77d07b2a18645c6637b09f6ec9a47e /gnu/packages/audio.scm
parentae5525c59114e54698c3e24e1a672ad333153a96 (diff)
downloadpatches-bcdf11d6ffd8cc55653ff0257f7a832aaa385c60.tar
patches-bcdf11d6ffd8cc55653ff0257f7a832aaa385c60.tar.gz
gnu: rtmidi: Update to 4.0.0.
* gnu/packages/audio.scm (rtmidi): Update to 4.0.0. [source]: Download tarball from upstream URL rather than the powertab github fork. [arguments]: Enable tests. Remove 'build and 'install phases and add a new 'noconfigure phase to prevent the bootstrap script from invoking configure. [home-page]: Update homepage to upstream URL. * gnu/packages/music.scm (powertabeditor)[arguments]: Add phase that substitutes the rtmidi #include directive to find the header. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm31
1 files changed, 10 insertions, 21 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3c7a882404..d59b4eb87e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2341,33 +2341,22 @@ tempo and pitch of an audio recording independently of one another.")
(define-public rtmidi
(package
(name "rtmidi")
- (version "2.1.0")
+ (version "4.0.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/powertab/rtmidi.git")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://www.music.mcgill.ca/~gary/rtmidi"
+ "/release/rtmidi-" version ".tar.gz"))
+ (file-name (string-append "rtmidi-" version ".tar.gz"))
(sha256
(base32
- "106v177y3nrjv2l1yskch4phpqd8h97b67zj0jiq9pc3c69jr1ay"))))
+ "1k962ljpnwyjw9jjiky2372khhri1wqvrj5qsalfpys31xqzw31p"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no "check" target
- #:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-before 'build 'fix-makefile
- (lambda _
- (substitute* "Makefile"
- (("/bin/ln") "ln")
- (("RtMidi.h RtError.h") "RtMidi.h"))
- #t))
- (add-before 'install 'make-target-dirs
+ (add-before 'bootstrap 'noconfigure
(lambda _
- (let ((out (assoc-ref %outputs "out")))
- (mkdir-p (string-append out "/bin"))
- (mkdir (string-append out "/lib"))
- (mkdir (string-append out "/include")))
+ (setenv "NOCONFIGURE" "yes")
#t)))))
(inputs
`(("jack" ,jack-1)
@@ -2377,7 +2366,7 @@ tempo and pitch of an audio recording independently of one another.")
("automake" ,automake)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
- (home-page "https://github.com/powertab/rtmidi")
+ (home-page "https://www.music.mcgill.ca/~gary/rtmidi")
(synopsis "Cross-platform MIDI library for C++")
(description
"RtMidi is a set of C++ classes (RtMidiIn, RtMidiOut, and API specific