summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2019-11-19 16:29:59 -0500
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2019-11-21 07:46:35 -0500
commit615a4fbff8baa77fa2b6355dc93faac421c66b93 (patch)
tree15ae339946e007f825780328855cb53b6d126e1a /gnu/packages/audio.scm
parentfe9b72c5861fabdf7f37862de393812ff3e423ac (diff)
downloadpatches-615a4fbff8baa77fa2b6355dc93faac421c66b93.tar
patches-615a4fbff8baa77fa2b6355dc93faac421c66b93.tar.gz
gnu: Add ecasound.
* gnu/packages/audio.scm (ecasound): Add it.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e10af39950..a070377d49 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3867,3 +3868,46 @@ over OSC. Carla currently supports LADSPA (including LRDF), DSSI, LV2, VST2,
and VST3 plugin formats, plus SF2 and SFZ file support. It uses JACK as the
default and preferred audio driver but also supports native drivers like ALSA.")
(license license:gpl2+)))
+
+(define-public ecasound
+ (package
+ (name "ecasound")
+ (version "2.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://nosignal.fi/download/ecasound-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "15rcs28fq2wfvfs66p5na7adq88b55qszbhshpizgdbyqzgr2jf1"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ ;; would be nice to add mikmod to inputs if that gets packaged
+ ;; eventually
+ (inputs `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("mpg123" ,mpg123)
+ ("lame" ,lame)
+ ("vorbis-tools" ,vorbis-tools)
+ ("faad2" ,faad2)
+ ("flac" ,flac)
+ ("timidity++" ,timidity++)
+ ("libsndfile" ,libsndfile)
+ ("libsamplerate" ,libsamplerate)
+ ("ncurses" ,ncurses)
+ ("ladspa" ,ladspa)
+ ("lilv" ,lilv)))
+ (home-page "http://nosignal.fi/ecasound/index.php")
+ (synopsis "Multitrack audio processing")
+ (description "Ecasound is a software package designed for multitrack audio
+processing. It can be used for simple tasks like audio playback, recording and
+format conversions, as well as for multitrack effect processing, mixing,
+recording and signal recycling. Ecasound supports a wide range of audio inputs,
+outputs and effect algorithms. Effects and audio objects can be combined in
+various ways, and their parameters can be controlled by operator objects like
+oscillators and MIDI-CCs. A versatile console mode user-interface is included
+in the package.")
+ ;; As an exception to the above, the C, C++ and python implementations
+ ;; of the Ecasound Control Interface (ECI) are licensed under the LGPL
+ ;; (see the file 'COPYING.LGPL'). This allows writing ECI applications
+ ;; that are not licensed under GPL.
+ (license (list license:gpl2 license:lgpl2.1))))