summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-01 13:18:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-01 13:18:47 +0100
commitbee7bb315cd0b4529a4117b6220c29ca297fc023 (patch)
treefe4741f257e50782e51bc2955ad4480cd2ba6396 /gnu/packages/astronomy.scm
parentc2f0e5a44b537632c2655f97a2539c3bf02c8a63 (diff)
parent8a4644336d5063fd0bf43e90e3c0823c76e82e4e (diff)
downloadpatches-bee7bb315cd0b4529a4117b6220c29ca297fc023.tar
patches-bee7bb315cd0b4529a4117b6220c29ca297fc023.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c3a591baa3..2bbdfb58d7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -21,6 +21,7 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (gnu packages image)
#:use-module (gnu packages compression)
#:use-module (gnu packages gettext)
@@ -34,16 +35,18 @@
(define-public cfitsio
(package
(name "cfitsio")
- (version "3390")
+ (version "3.420")
(source
(origin
(method url-fetch)
(uri (string-append
- "http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/" name version
- ".tar.gz"))
+ "http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/"
+ name (string-replace-substring version "." "") ".tar.gz"))
(sha256
- (base32 "02gllydm63irwbqqisa3mrskw1fphm5rlplglz3mq9whi3rxilv2"))))
+ (base32 "1f0nmki45h9kw7vxpxiav9cb6vs3qqi6zrp2lpci5yhqc5isl43c"))))
(build-system gnu-build-system)
+ ;; XXX Building with curl currently breaks wcslib. It doesn't use
+ ;; pkg-config and hence won't link with -lcurl.
(arguments
`(#:tests? #f ; no tests
#:phases
@@ -55,7 +58,7 @@
(home-page "http://heasarc.gsfc.nasa.gov/fitsio/fitsio.html")
(synopsis "Library for reading and writing FITS files")
(description "CFITSIO provides simple high-level routines for reading and
-writing FITS (Flexible Image Transport System) files that insulate the
+writing @dfn{FITS} (Flexible Image Transport System) files that insulate the
programmer from the internal complexities of the FITS format. CFITSIO also
provides many advanced features for manipulating and filtering the information
in FITS files.")