summaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
commit961d2ee2695b38503b463d055e9c7edbcc0bf307 (patch)
tree82d9b40477a1d4d88e75a187b2b637a56751480b /gnu/packages/assembly.scm
parent7cf79d7a51ff5dde4fc430fab2296b5f7de08953 (diff)
parentaebba13c0bef5a58697f1a9fe8337967cc01300f (diff)
downloadpatches-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar
patches-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 0fdddc88e9..0a24220e18 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2019 Andy Tai <atai@atai.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,3 +343,31 @@ Supported architectures are:
@item spc700
@end itemize")
(license license:gpl2)))
+
+(define-public xa
+ (package
+ (name "xa")
+ (version "2.3.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.floodgap.com/retrotech/xa"
+ "/dists/xa-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0y5sd247g11jfk5msxy91hz2nhpy7smj125dzfyfhjsjnqk5nyw6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; TODO: custom test harness, not sure how it works
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no "configure" script
+ #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+ (native-inputs `(("perl" ,perl)))
+ (home-page "https://www.floodgap.com/retrotech/xa/")
+ (synopsis "Two-pass portable cross-assembler")
+ (description
+ "xa is a high-speed, two-pass portable cross-assembler.
+It understands mnemonics and generates code for NMOS 6502s (such
+as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...),
+ CMOS 6502s (65C02 and Rockwell R65C02) and the 65816.")
+ (license license:gpl2)))