summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-13 00:32:55 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-13 00:32:55 +0100
commit22c334fa2e9c42fd79eef86f71a704c437ac917e (patch)
tree22c85b9c816015899750d9c411b940f43b39ec3f /gnu/packages/aspell.scm
parent0dcf675c56a4649ccef657e78849e91f9f9b4c0a (diff)
downloadpatches-22c334fa2e9c42fd79eef86f71a704c437ac917e.tar
patches-22c334fa2e9c42fd79eef86f71a704c437ac917e.tar.gz
gnu: hunspell-dict-en: Include all the .dic files.
Fixes a regression introduced in d4d7d70912642be18d93c9ce6470f8650097b5e5 which broke 'hunspell-dict-en' (but not the 'hunspell-dict-en-*' variants.) * gnu/packages/aspell.scm (aspell-word-list)[install]: Check whether 'LANGUAGE.dic' exist before installing it. If it doesn't exist, install all of *.dic.
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index ec8fa05feb..e1fe3db755 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
@@ -268,10 +268,20 @@ dictionaries, including personal ones.")
(hunspell (string-append out "/share/hunspell"))
(myspell (string-append out "/share/myspell"))
(doc (string-append out "/share/doc/"
- ,name)))
+ ,name))
+ (dot-dic ,(string-append "speller/" language ".dic")))
(mkdir-p myspell)
- (install-file ,(string-append "speller/" language ".dic")
- hunspell)
+
+ ;; Usually there's only a 'LANGUAGE.dic' file, but for the "en"
+ ;; dictionary, there no 'en.dic'. Instead, there's a set of
+ ;; 'en*.dic' files, hence the 'find-files' call below.
+ (if (file-exists? dot-dic)
+ (install-file dot-dic hunspell)
+ (for-each (lambda (dic)
+ (install-file dic hunspell))
+ (find-files "speller"
+ ,(string-append language ".*\\.dic$"))))
+
(install-file ,(string-append "speller/" language ".aff")
hunspell)
(symlink hunspell (string-append myspell "/dicts"))