summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-01-20 23:07:20 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-20 23:07:20 +0100
commit7175abaaa47e7d903008fa8944faef189b208107 (patch)
treebcad013af43d5d4d054af7acff953824d9dea8ed /gnu/packages/android.scm
parent6ef5162d659b8f44fc2f16b3d9dff9062e60d774 (diff)
downloadpatches-7175abaaa47e7d903008fa8944faef189b208107.tar
patches-7175abaaa47e7d903008fa8944faef189b208107.tar.gz
gnu: Add mkbootimg.
* gnu/packages/android.scm (mkbootimg): New variable.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 37f472bcba..6baefbca96 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -311,6 +311,33 @@ of device actions, such as installing and debugging apps, and it provides access
to a Unix shell that can run commands on the connected device or emulator.")
(license license:asl2.0)))
+(define-public mkbootimg
+ (package
+ (name "mkbootimg")
+ (version (android-platform-version))
+ (source (origin
+ (inherit (android-platform-system-core version))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-source
+ (lambda _ (chdir "mkbootimg") #t))
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "mkbootimg" bin)
+ #t))))))
+ (home-page "https://developer.android.com/studio/command-line/adb.html")
+ (synopsis "Tool to create Android boot images")
+ (description "This package provides a tool to create Android Boot
+Images.")
+ (license license:asl2.0)))
+
(define-public android-udev-rules
(package
(name "android-udev-rules")