summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-04-26 02:52:18 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-09 22:20:14 +0200
commitcbf83e00909ed0ec2403e0e85c1bc24fd159c021 (patch)
tree9bb1d8f67f766daa6d124812fa348ed17016f18c /gnu/packages/android.scm
parentcc39d592d92102091c8d73ce6e6e63fde5e9e030 (diff)
downloadpatches-cbf83e00909ed0ec2403e0e85c1bc24fd159c021.tar
patches-cbf83e00909ed0ec2403e0e85c1bc24fd159c021.tar.gz
gnu: libcutils: Install header files.
* gnu/packages/android.scm (libcutils)[arguments]<#:phases>[install]: Install header files.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 17c9de70a5..c3174babbd 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -210,10 +210,13 @@ various Android core host applications.")
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib")))
+ (lib (string-append out "/lib"))
+ (include (string-append out "/include")))
(install-file "libcutils.so.0" lib)
(with-directory-excursion lib
(symlink "libcutils.so.0" "libcutils.so"))
+ (copy-recursively "../include/cutils"
+ (string-append include "/cutils"))
#t))))))
(home-page "https://developer.android.com/")
(synopsis "Android platform c utils library")