summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-07-23 11:23:11 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-07-23 11:26:46 -0400
commit2cdb257ee3d91da797737d7bca9cd1788a06eb7e (patch)
treeea4bdbaaf832596b7c6f7808ebd3b1a30a9a28c2 /gnu/packages/algebra.scm
parentfef7baba786a96b7a3100c9c7adf8b45782ced37 (diff)
downloadpatches-2cdb257ee3d91da797737d7bca9cd1788a06eb7e.tar
patches-2cdb257ee3d91da797737d7bca9cd1788a06eb7e.tar.gz
gnu: arb: Update to 2.14.0.
* gnu/packages/algebra.scm (arb): Update to 2.14.0. [arguments]: Substitute invoke for system*. [license]: Change to lgpl2.1+.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2a17ea59b6..c889433b41 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -315,7 +315,7 @@ fast arithmetic.")
(define-public arb
(package
(name "arb")
- (version "2.13.0")
+ (version "2.14.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -324,7 +324,7 @@ fast arithmetic.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "123p3gwx0s3i88rcaj3g4jl37cr3pywhpqackipskzab15ni2xfh"))))
+ "0ncr27nd20xxi18nj30cvpa6r52v59nq7gbi34x3l4xym3p8mlmx"))))
(build-system gnu-build-system)
(propagated-inputs
`(("flint" ,flint))) ; flint.h is included by arf.h
@@ -342,19 +342,18 @@ fast arithmetic.")
(mpfr (assoc-ref inputs "mpfr")))
;; do not pass "--enable-fast-install", which makes the
;; homebrew configure process fail
- (zero? (system*
- "./configure"
+ (invoke "./configure"
(string-append "--prefix=" out)
(string-append "--with-flint=" flint)
(string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr)))))))))
+ (string-append "--with-mpfr=" mpfr))))))))
(synopsis "Arbitrary precision floating-point ball arithmetic")
(description
"Arb is a C library for arbitrary-precision floating-point ball
arithmetic. It supports efficient high-precision computation with
polynomials, power series, matrices and special functions over the
real and complex numbers, with automatic, rigorous error control.")
- (license license:gpl2+)
+ (license license:lgpl2.1+)
(home-page "http://fredrikj.net/arb/")))
(define-public ntl