aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-08 23:08:56 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-08 23:08:56 +0200
commitdb7441e4705ee22d9f8abbb764201144ced878cb (patch)
treef6ddf1363ed2283ddd937434465bdf8e84c30c1b /gnu/packages/algebra.scm
parentaa07299f1fcae53bfec353a0b05b944dab4f7bc6 (diff)
parent2afb79392d39df05e5b285ea46dd59eafb0616d8 (diff)
downloadpatches-db7441e4705ee22d9f8abbb764201144ced878cb.tar
patches-db7441e4705ee22d9f8abbb764201144ced878cb.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 205eb29863..9b4c7b8e27 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -56,6 +56,7 @@
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix hg-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils))
@@ -857,6 +858,32 @@ features, and more.")
;; See 'COPYING.README' for details.
(license license:mpl2.0)))
+(define-public eigen-for-tensorflow
+ (let ((changeset "fd6845384b86")
+ (revision "1"))
+ (package (inherit eigen)
+ (name "eigen-for-tensorflow")
+ (version (string-append "3.3.5-" revision "." changeset))
+ (source (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://bitbucket.org/eigen/eigen")
+ (changeset changeset)))
+ (sha256
+ (base32
+ "12cwgah63wqwb66xji048hcxc1z5zjg8a7701zlia5zbilnnk1n5"))
+ (file-name (string-append name "-" version "-checkout"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; There are 3 test failures in the "unsupported" directory,
+ ;; but maintainers say it's a known issue and it's unsupported
+ ;; anyway, so just skip them.
+ '(begin
+ (substitute* "unsupported/CMakeLists.txt"
+ (("add_subdirectory\\(test.*")
+ "# Do not build the tests for unsupported features.\n"))
+ #t)))))))
+
(define-public xtensor
(package
(name "xtensor")