summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-10 17:32:24 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-10 17:32:24 +0200
commit4d14902b9402a83db444d8d6818d0a4f438ce8c4 (patch)
tree85f05a0540ebcd4a1f192096c36271a287eb9fe8 /gnu/packages/algebra.scm
parent647cfcf68184e8558fcea751ef6d95b6e5d86ae1 (diff)
parent6c50e1dc0625f89884cff40b22627091efa37708 (diff)
downloadpatches-4d14902b9402a83db444d8d6818d0a4f438ce8c4.tar
patches-4d14902b9402a83db444d8d6818d0a4f438ce8c4.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 956f349d0b..5be2733053 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -345,7 +345,7 @@ precision.")
(define-public giac
(package
(name "giac")
- (version "1.5.0-63")
+ (version "1.5.0-65")
(source (origin
(method url-fetch)
;; "~parisse/giac" is not used because the maintainer regularly
@@ -357,7 +357,7 @@ precision.")
"source/giac_" version ".tar.gz"))
(sha256
(base32
- "1jp7awyp8j8w6fhn802z8ddbq1fxhkyk9xdf0mq0mm0chpkylwqk"))))
+ "1g2fp9vgy0gqjmi6mlc3ldfn8ryq3h4mfd7rcq5hs6ry21hblv30"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 ftw)
@@ -996,7 +996,7 @@ features, and more.")
(define-public xtensor
(package
(name "xtensor")
- (version "0.20.5")
+ (version "0.20.9")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1004,7 +1004,7 @@ features, and more.")
(commit version)))
(sha256
(base32
- "0kkc4ar7p2d94jnclmrh46dwv7ldy9lx630vm9gci3pp4hnhbj9f"))
+ "1rw04bdi7mzp362dhkxr9m4rafnvb47xjsi9p3fp4vfif8v0jij8"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
@@ -1014,7 +1014,7 @@ features, and more.")
`(#:configure-flags
'("-DBUILD_TESTS=ON")
#:test-target "xtest"))
- (home-page "http://quantstack.net/xtensor")
+ (home-page "https://quantstack.net/xtensor")
(synopsis "C++ tensors with broadcasting and lazy computing")
(description "xtensor is a C++ library meant for numerical analysis with
multi-dimensional array expressions.