summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-14 12:26:02 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-15 18:51:00 +0200
commitf71f29cab2b484ea8e63d29a5766f680d0e800c1 (patch)
tree1a384b09c781d5be6a92b27d3e50c79d0e195678 /gnu/packages/algebra.scm
parente5da4d8b4027a8300ee80a970e8628266609c126 (diff)
downloadpatches-f71f29cab2b484ea8e63d29a5766f680d0e800c1.tar
patches-f71f29cab2b484ea8e63d29a5766f680d0e800c1.tar.gz
gnu: bc: Update to 1.07.1.
* gnu/packages/algebra.scm (bc): Update to 1.07.1. [native-inputs]: Add ED and TEXINFO. [arguments]<#:phases>: Remove.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm31
1 files changed, 10 insertions, 21 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index ab73a6e2e5..670a8954a9 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages ed)
#:use-module (gnu packages flex)
#:use-module (gnu packages fltk)
#:use-module (gnu packages gl)
@@ -39,6 +41,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages shells)
#:use-module (gnu packages tex)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
@@ -468,35 +471,21 @@ binary.")
(define-public bc
(package
(name "bc")
- (version "1.06")
+ (version "1.07.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/bc/bc-" version ".tar.gz"))
(sha256
(base32
- "0cqf5jkwx6awgd2xc2a0mkpxilzcfmhncdcfg7c9439wgkqxkxjf"))))
+ "0amh9ik44jfg66csyvf4zz1l878c4755kjndq9j0270akflgrbb2"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
- (native-inputs `(("flex" ,flex)))
+ (native-inputs
+ `(("ed" ,ed)
+ ("flex" ,flex)
+ ("texinfo" ,texinfo)))
(arguments
- '(#:phases
- (alist-replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system*
- "./configure"
- (string-append "--prefix=" out)
- ;; By default, man and info pages are put in
- ;; PREFIX/{man,info}, but we want them in
- ;; PREFIX/share/{man,info}.
- (string-append "--mandir=" out "/share/man")
- (string-append "--infodir=" out "/share/info")))))
- %standard-phases)
- #:configure-flags
+ '(#:configure-flags
(list "--with-readline")))
(home-page "https://www.gnu.org/software/bc/")
(synopsis "Arbitrary precision numeric processing language")