summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-02 14:45:15 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-02 14:54:24 +0100
commit7355634db3ccf0d86f8e34c4aea37392c1a0ab0a (patch)
tree424f82554e955eec521b70eab1543ca822490f10 /gnu/packages/algebra.scm
parent9af076245f2e9e708314e4267c2f7c732aaff3b2 (diff)
downloadpatches-7355634db3ccf0d86f8e34c4aea37392c1a0ab0a.tar
patches-7355634db3ccf0d86f8e34c4aea37392c1a0ab0a.tar.gz
gnu: Disambiguate packages with the same name.
* gnu/packages/algebra.scm (fftw-with-threads, fftwf-with-threads): Add 'name' field. * gnu/packages/llvm.scm (llvm-for-extempore): Likewise.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 8e3327eafe..892b6cf525 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
@@ -581,6 +581,7 @@ cosine/ sine transforms or DCT/DST).")
;; "--enable-flags" is added to the fftw and fftwf packages.
(define-public fftw-with-threads
(package (inherit fftw)
+ (name "fftw-pthreads")
(arguments
(substitute-keyword-arguments (package-arguments fftw)
((#:configure-flags flags)
@@ -588,6 +589,7 @@ cosine/ sine transforms or DCT/DST).")
(define-public fftwf-with-threads
(package (inherit fftwf)
+ (name "fftwf-pthreads")
(arguments
(substitute-keyword-arguments (package-arguments fftwf)
((#:configure-flags flags)