summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 21:46:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 03:01:39 +0100
commitb07e817e21b794ec81499dc38125775d6722cc48 (patch)
tree399cbd234f0d4e90df088bc4fd3fd704e8a15e9f /gnu/packages/algebra.scm
parenta0d4d2d8605e771eefde8713756c5d6c3f98c9f7 (diff)
downloadpatches-b07e817e21b794ec81499dc38125775d6722cc48.tar
patches-b07e817e21b794ec81499dc38125775d6722cc48.tar.gz
gnu: fftw: Update phase style.
* gnu/packages/algebra.scm (fftw)[arguments]: Use MODIFY-PHASES syntax and end phase with #t.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index f90439655f..8c42ac31cc 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -530,16 +530,17 @@ a C program.")
(arguments
'(#:configure-flags
'("--enable-shared" "--enable-openmp" "--enable-threads")
- #:phases (alist-cons-before
- 'build 'no-native
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'no-native
(lambda _
;; By default '-mtune=native' is used. However, that may
;; cause the use of ISA extensions (SSE2, etc.) that are
;; not necessarily available on the user's machine when
;; that package is built on a different machine.
(substitute* (find-files "." "Makefile$")
- (("-mtune=native") "")))
- %standard-phases)))
+ (("-mtune=native") ""))
+ #t)))))
(native-inputs `(("perl" ,perl)))
(home-page "http://fftw.org")
(synopsis "Computing the discrete Fourier transform")