summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-03-19 10:44:15 +0100
committerAndreas Enge <andreas@enge.fr>2019-03-19 10:45:17 +0100
commit1d6589db81c7c390e04795805e684b01f5a0c45f (patch)
tree88a1eac7b993ee2efc76341f2c5cab9e1dee38a3 /gnu/packages/algebra.scm
parent835dada6e4e4a99c79498eef002934a4b4ee456d (diff)
downloadpatches-1d6589db81c7c390e04795805e684b01f5a0c45f.tar
patches-1d6589db81c7c390e04795805e684b01f5a0c45f.tar.gz
gnu: Add python-flint.
* gnu/packages/algebra.scm (python-flint): New variable. * gnu/packages/patches/python-flint-includes.patch: New file. * gnu/local.mk (dist_patch_DATA): Register the patch.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2849a565c3..e272cd990b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages shells)
#:use-module (gnu packages tex)
@@ -52,6 +53,7 @@
#:use-module (guix build-system ant)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -421,6 +423,38 @@ real and complex numbers, with automatic, rigorous error control.")
(license license:lgpl2.1+)
(home-page "http://fredrikj.net/arb/")))
+(define-public python-flint
+ (package
+ (name "python-flint")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fredrik-johansson/python-flint.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v0anazbj1cfi68nl2j6dbd31kgkc1563xmr0zk5xk3xj78569pw"))
+ (patches (search-patches "python-flint-includes.patch"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (inputs
+ `(("arb" ,arb)
+ ("flint" ,flint)))
+ (synopsis "Python module wrapping ARB and FLINT")
+ (description
+ "Python-flint is a Python extension module wrapping FLINT
+(Fast Library for Number Theory) and Arb (arbitrary-precision ball
+arithmetic). It supports integers, rationals, modular integers,
+real and complex ball arithmetic, polynomials and matrices over all
+these types and other mathematical functions.")
+ (license license:expat)
+ (home-page "http://fredrikj.net/python-flint/")))
+
(define-public ntl
(package
(name "ntl")