summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-30 12:17:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-30 12:17:33 +0200
commitae0badf5bb791428423a98d4e4e2b8d297a5d4be (patch)
tree4282d243db3e90839a5f7d3b5878674ccd0e2e14 /gnu/packages/algebra.scm
parentee401ed9249fbe284ef1b9b437d39207ca88131b (diff)
parent927f3655662b41f25225ea03baa3ded687aa7cbb (diff)
downloadpatches-ae0badf5bb791428423a98d4e4e2b8d297a5d4be.tar
patches-ae0badf5bb791428423a98d4e4e2b8d297a5d4be.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/guile.scm gnu/packages/linux.scm gnu/packages/package-management.scm gnu/packages/pulseaudio.scm gnu/packages/web.scm
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm43
1 files changed, 24 insertions, 19 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index e2e26c8c25..4ff766eef1 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -433,9 +434,6 @@ maple, mupad and the TI89. It is available as a standalone program (graphic
or text interfaces) or as a C++ library.")
(license license:gpl3+)))
-(define-public giac-xcas
- (deprecated-package "giac-xcas" giac))
-
(define-public flint
(package
(name "flint")
@@ -562,42 +560,50 @@ these types and other mathematical functions.")
(define-public ntl
(package
(name "ntl")
- (version "9.7.0")
+ (version "11.4.3")
(source (origin
(method url-fetch)
- (uri (string-append "http://shoup.net/ntl/ntl-"
+ (uri (string-append "https://shoup.net/ntl/ntl-"
version ".tar.gz"))
- (sha256 (base32
- "115frp5flyvw9wghz4zph1b3llmr5nbxk1skgsggckr81fh3gmxq"))))
+ (sha256
+ (base32
+ "1lisp3064rch3jaa2wrhy1s9kll7i3ka3d0y6lj6l3l4ckfcrhdp"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "src/libtool-origin")
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("libtool" ,libtool)
("perl" ,perl))) ; for configuration
- ;; FIXME: Add optional input gf2x once available; then also add
- ;; configure flag "NTL_GF2X_LIB=on".
(inputs
- `(("gmp" ,gmp)))
+ `(("gmp" ,gmp)
+ ("gf2x" ,gf2x)))
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(chdir "src")
- (system* "./configure"
+ (invoke "./configure"
(string-append "PREFIX=" (assoc-ref outputs "out"))
+ (string-append "LIBTOOL=" (assoc-ref inputs "libtool") "/bin/libtool")
+ ;; set the library prefixes explicitly so that they get
+ ;; embedded in the .la file
+ (string-append "GMP_PREFIX=" (assoc-ref inputs "gmp"))
+ (string-append "GF2X_PREFIX=" (assoc-ref inputs "gf2x"))
;; Do not build especially for the build machine.
"NATIVE=off"
- ;; Also do not tune to the build machine.
- "WIZARD=off"
- "SHARED=on")
- #t)))))
+ "NTL_GF2X_LIB=on"
+ "SHARED=on"))))))
(synopsis "C++ library for number theory")
(description
"NTL is a C++ library providing data structures and algorithms
for manipulating signed, arbitrary length integers, and for vectors,
matrices, and polynomials over the integers and over finite fields.")
(license license:gpl2+)
- (home-page "http://shoup.net/ntl/")))
+ (home-page "https://shoup.net/ntl/")))
(define-public singular
(package
@@ -1437,8 +1443,7 @@ of M4RI from F_2 to F_{2^e}.")
("automake" ,automake)
("libtool" ,libtool)))
(inputs
- `(("gmp" ,gmp)
- ("ntl" ,ntl)
+ `(("ntl" ,ntl)
("pari-gp" ,pari-gp)))
(synopsis "Ranks of elliptic curves and modular symbols")
(description "The eclib package includes mwrank (for 2-descent on