summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-08-06 00:23:20 -0400
committerMark H Weaver <mhw@netris.org>2017-08-06 00:23:20 -0400
commitf167595ba1a4e0e419adc17de6af275bedf32822 (patch)
tree6a582fbda8ad9d72962359add99e5ae219dd030d /gnu/packages/admin.scm
parente3df6938acc2ba2d2f7333d911b8bdc3697f0f75 (diff)
parent01a61d7040b1794f36547b107abce6e967d59f21 (diff)
downloadpatches-f167595ba1a4e0e419adc17de6af275bedf32822.tar
patches-f167595ba1a4e0e419adc17de6af275bedf32822.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 02d9baf493..e8a1cb552c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1718,7 +1718,7 @@ throughput (in the same interval).")
(define-public thefuck
(package
(name "thefuck")
- (version "3.18")
+ (version "3.19")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/nvbn/thefuck/archive/"
@@ -1726,7 +1726,7 @@ throughput (in the same interval).")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1xsvkqh89rgxq5w03mnlcfkn9y39nfwhb2pjabjspcc2mi2mq5y6"))
+ "191zbvkyc02h0wwd46xwj4zzg7jhlr8xv0ji6knqkgjnk0nvqq01"))
(patches (search-patches "thefuck-test-environ.patch"))))
(build-system python-build-system)
(arguments
@@ -2105,28 +2105,22 @@ Intel DRM Driver.")
(define-public fabric
(package
(name "fabric")
- (version "1.13.1")
+ (version "1.13.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Fabric" version))
(sha256
(base32
- "1z17hw0yiqp1blq217zxkg2jzkv8qd79saqhscgsw14mwlcqpwd0"))
- (patches (search-patches "fabric-tests.patch"))))
+ "0k944dxr41whw7ib6380q9x15wyskx7fqni656icdn8rzshn9bwq"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2)) ;Python 2 only
+ `(#:python ,python-2)) ; Python 2 only
(native-inputs
- `(("python2-fudge" ,python2-fudge) ; Requires < 1.0
- ("python2-jinja2" ,python2-jinja2) ; Requires < 3.0
- ("python2-nose" ,python2-nose))) ; Requires < 2.0
+ `(("python2-fudge" ,python2-fudge)
+ ("python2-jinja2" ,python2-jinja2)
+ ("python2-nose" ,python2-nose)))
(propagated-inputs
- ;; Required upgrading python-paramiko 1.17.4 to fix an incompatibility
- ;; between python-paramiko and newer python-pycrypto. Without this, the
- ;; `fab` command fails with "ValueError: CTR mode needs counter
- ;; parameter, not IV". See:
- ;; https://github.com/paramiko/paramiko/pull/714#issuecomment-281191548.
`(("python2-paramiko" ,python2-paramiko)))
(home-page "http://fabfile.org")
(synopsis "Simple Pythonic remote execution and deployment tool")