summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-04 03:46:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-04 03:46:49 +0200
commitf58be417610e65f27b90452b78255f8d88ab1b4f (patch)
treeb9943a1db4cd177ceec7bbc4a0ce2b8cae1c8abf /gnu/packages/admin.scm
parent19dd5097d936aadf2a4da266c377ed8a4fb381c8 (diff)
downloadpatches-f58be417610e65f27b90452b78255f8d88ab1b4f.tar
patches-f58be417610e65f27b90452b78255f8d88ab1b4f.tar.gz
gnu: fabric: Update to 1.13.2.
* gnu/packages/admin.scm (fabric): Update to 1.13.2. Remove outdated comments. [source]: Remove ‘patches’. * gnu/packages/patches/fabric-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 45f743199a..c4aa108f89 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2105,28 +2105,22 @@ Intel DRM Driver.")
(define-public fabric
(package
(name "fabric")
- (version "1.13.1")
+ (version "1.13.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Fabric" version))
(sha256
(base32
- "1z17hw0yiqp1blq217zxkg2jzkv8qd79saqhscgsw14mwlcqpwd0"))
- (patches (search-patches "fabric-tests.patch"))))
+ "0k944dxr41whw7ib6380q9x15wyskx7fqni656icdn8rzshn9bwq"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2)) ;Python 2 only
+ `(#:python ,python-2)) ; Python 2 only
(native-inputs
- `(("python2-fudge" ,python2-fudge) ; Requires < 1.0
- ("python2-jinja2" ,python2-jinja2) ; Requires < 3.0
- ("python2-nose" ,python2-nose))) ; Requires < 2.0
+ `(("python2-fudge" ,python2-fudge)
+ ("python2-jinja2" ,python2-jinja2)
+ ("python2-nose" ,python2-nose)))
(propagated-inputs
- ;; Required upgrading python-paramiko 1.17.4 to fix an incompatibility
- ;; between python-paramiko and newer python-pycrypto. Without this, the
- ;; `fab` command fails with "ValueError: CTR mode needs counter
- ;; parameter, not IV". See:
- ;; https://github.com/paramiko/paramiko/pull/714#issuecomment-281191548.
`(("python2-paramiko" ,python2-paramiko)))
(home-page "http://fabfile.org")
(synopsis "Simple Pythonic remote execution and deployment tool")