summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-08-09 17:25:31 -0400
committerMark H Weaver <mhw@netris.org>2017-08-09 17:25:31 -0400
commitcc294bcee6bfaa4524ac43450e41f083539f9cb1 (patch)
tree1248811a6fd39e9169fd4b3c58f456bd21d1c7d5 /gnu/packages/admin.scm
parent32b7506c987d8b7281382da4831958a64c048fc1 (diff)
parentae7f246cf1c7e20ebf4025024bb10361938abaa2 (diff)
downloadpatches-cc294bcee6bfaa4524ac43450e41f083539f9cb1.tar
patches-cc294bcee6bfaa4524ac43450e41f083539f9cb1.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e8a1cb552c..a9cb2a52ac 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
-;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
@@ -849,29 +849,29 @@ system administrator.")
;; Avoid non-determinism; see <http://bugs.gnu.org/21918>.
#:parallel-build? #f
- #:phases (alist-cons-before
- 'configure 'pre-configure
- (lambda _
- (substitute* "src/sudo_usage.h.in"
- ;; Do not capture 'configure' arguments since we would
- ;; unduly retain references, and also because the
- ;; CPPFLAGS above would close the string literal
- ;; prematurely.
- (("@CONFIGURE_ARGS@") "\"\""))
- (substitute* (find-files "." "Makefile\\.in")
- (("-o [[:graph:]]+ -g [[:graph:]]+")
- ;; Allow installation as non-root.
- "")
- (("^install: (.*)install-sudoers(.*)" _ before after)
- ;; Don't try to create /etc/sudoers.
- (string-append "install: " before after "\n"))
- (("\\$\\(DESTDIR\\)\\$\\(rundir\\)")
- ;; Don't try to create /run/sudo.
- "$(TMPDIR)/dummy")
- (("\\$\\(DESTDIR\\)\\$\\(vardir\\)")
- ;; Don't try to create /var/db/sudo.
- "$(TMPDIR)/dummy")))
- %standard-phases)
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _
+ (substitute* "src/sudo_usage.h.in"
+ ;; Do not capture 'configure' arguments since we would
+ ;; unduly retain references, and also because the
+ ;; CPPFLAGS above would close the string literal
+ ;; prematurely.
+ (("@CONFIGURE_ARGS@") "\"\""))
+ (substitute* (find-files "." "Makefile\\.in")
+ (("-o [[:graph:]]+ -g [[:graph:]]+")
+ ;; Allow installation as non-root.
+ "")
+ (("^install: (.*)install-sudoers(.*)" _ before after)
+ ;; Don't try to create /etc/sudoers.
+ (string-append "install: " before after "\n"))
+ (("\\$\\(DESTDIR\\)\\$\\(rundir\\)")
+ ;; Don't try to create /run/sudo.
+ "$(TMPDIR)/dummy")
+ (("\\$\\(DESTDIR\\)\\$\\(vardir\\)")
+ ;; Don't try to create /var/db/sudo.
+ "$(TMPDIR)/dummy")))))
;; XXX: The 'testsudoers' test series expects user 'root' to exist, but
;; the chroot's /etc/passwd doesn't have it. Turn off the tests.