summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-23 03:42:12 -0400
committerLeo Famulari <leo@famulari.name>2017-07-23 03:42:12 -0400
commit6c1a317e29c45e85e3a0e050612cdefe470b100c (patch)
treee65dedf933090b1a9f8398655b3b20eba49fae96 /gnu/packages/admin.scm
parentb7158b767b7fd9f0379dfe08083c48a0cf0f3d50 (diff)
parent9478c05955643f8ff95dabccc1e42b20abb88049 (diff)
downloadpatches-6c1a317e29c45e85e3a0e050612cdefe470b100c.tar
patches-6c1a317e29c45e85e3a0e050612cdefe470b100c.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5fa9d5b06c..2f58cb3a28 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -271,7 +271,13 @@ re-executing them as necessary.")
"05n65k4ixl85dc6rxc51b1b732gnmm8xnqi424dy9f1nz7ppb3xy"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--localstatedir=/var")
+ `(#:configure-flags '("--localstatedir=/var"
+
+ ;; Make sure 'PATH_PROCNET_DEV' gets defined when
+ ;; cross-compiling (by default it does not.)
+ ,@(if (%current-target-system)
+ '("--with-path-procnet-dev=/proc/net/dev")
+ '()))
;; On some systems, 'libls.sh' may fail with an error such as:
;; "Failed to tell switch -a apart from -A".
#:parallel-tests? #f))
@@ -300,7 +306,7 @@ hostname.")
"0hdpai78n63l3v3fgr3kkiqzhd0awrpfnnzz4mf7lmxdh61qb37w"))))
(build-system gnu-build-system)
(arguments
- '(;; Assume System V `setpgrp (void)', which is the default on GNU
+ `(;; Assume System V `setpgrp (void)', which is the default on GNU
;; variants (`AC_FUNC_SETPGRP' is not cross-compilation capable.)
#:configure-flags
'("--with-libpam" "ac_cv_func_setpgrp_void=yes")
@@ -310,7 +316,10 @@ hostname.")
(add-before 'build 'set-nscd-file-name
(lambda* (#:key inputs #:allow-other-keys)
;; Use the right file name for nscd.
- (let ((libc (assoc-ref inputs "libc")))
+ (let ((libc (assoc-ref inputs
+ ,(if (%current-target-system)
+ "cross-libc"
+ "libc"))))
(substitute* "lib/nscd.c"
(("/usr/sbin/nscd")
(string-append libc "/sbin/nscd"))))))