summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2017-05-13 19:36:01 -0500
committerChristopher Allan Webber <cwebber@dustycloud.org>2017-05-14 18:56:27 -0500
commit589896843854cbdb24f627a53e5a9af628c6e7fb (patch)
treef802681817ae14a8b55dd6a963a739195e938ea6 /gnu/packages/admin.scm
parent73c791b8f3124b20e9bdd66428dbdf481ee12921 (diff)
downloadpatches-589896843854cbdb24f627a53e5a9af628c6e7fb.tar
patches-589896843854cbdb24f627a53e5a9af628c6e7fb.tar.gz
gnu: Add thermald.
* gnu/packages/admin.scm (thermald): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm54
1 files changed, 53 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ef7bff10f3..1610729c44 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
+;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,7 +81,8 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages gnome)
#:use-module (gnu packages kerberos)
- #:use-module (gnu packages gtk))
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages xml))
(define-public aide
(package
@@ -2180,3 +2182,53 @@ navigation, opening files and running tasks. There is no config file and
mime associations are hard-coded. The incredible user-friendliness and speed
make it a perfect utility on modern distros.")
(license license:bsd-2)))
+
+(define-public thermald
+ (package
+ (name "thermald")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/01org/thermal_daemon/archive/v"
+ version ".tar.gz"))
+ (sha256 (base32
+ "14klz9fnvi9jdlaqwrp61xa5nh051n8ykrs1fh1wxd7j66qf2fn6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after
+ 'unpack 'autogen.sh-and-fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; upstartconfir is hardcoded to /etc/init and the build
+ ;; system tries to mkdir that. We don't even need upstart
+ ;; files at all; this is a fast and kludgy workaround
+ (substitute* "data/Makefile.am"
+ (("upstartconfdir = /etc/init")
+ (string-append "upstartconfdir = "
+ out "/etc/init")))
+ ;; Now run autogen
+ (zero? (system* "sh" "autogen.sh"))))))
+ #:configure-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "--sysconfdir="
+ out "/etc")
+ (string-append "--with-udev-dir="
+ out "/lib/udev")
+ (string-append "--with-dbus-sys-dir="
+ out "/etc/dbus-1/system.d")
+ "--localstatedir=/var"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("glib" ,glib "bin") ; for glib-genmarshal, etc.
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dbus-glib" ,dbus-glib)
+ ("libxml2" ,libxml2)))
+ (home-page "https://01.org/linux-thermal-daemon/")
+ (synopsis "CPU scaling for thermal management")
+ (description "The Linux Thermal Daemon helps monitor and control temperature
+on systems running the Linux kernel.")
+ (license license:gpl2+)))