summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-14 00:13:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-14 15:54:27 +0200
commit24dd949c83f6a90f0a2388fc874968efd495a2db (patch)
treef8fe628a02917b045bfd80e1307ac5d1c0c1422f /gnu/packages/admin.scm
parent689aacc12f1d9c0b511e2010185b2e7a80de5201 (diff)
downloadpatches-24dd949c83f6a90f0a2388fc874968efd495a2db.tar
patches-24dd949c83f6a90f0a2388fc874968efd495a2db.tar.gz
gnu: libpcap: Update to 1.9.0.
* gnu/packages/admin.scm (libpcap): Update to 1.9.0. [arguments]: Drop ‘--with-pcap=linux’ ./configure flag. [license]: Update list.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 48b5c53562..ed476512d1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -751,27 +751,30 @@ tools: server, client, and relay agent.")
(define-public libpcap
(package
(name "libpcap")
- (version "1.8.1")
+ (version "1.9.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.tcpdump.org/release/libpcap-"
version ".tar.gz"))
(sha256
(base32
- "07jlhc66z76dipj4j5v3dig8x6h3k6cb36kmnmpsixf3zmlvqgb7"))))
+ "06bhydl4vr4z9c3vahl76f2j96z1fbrcl7wwismgs4sris08inrf"))))
(build-system gnu-build-system)
- (native-inputs `(("bison" ,bison) ("flex" ,flex)))
- (arguments '(#:configure-flags '("--with-pcap=linux")
- #:tests? #f)) ; no 'check' target
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)))
+ (arguments
+ ;; There are some tests in testprogs/, but no automated test suite.
+ '(#:tests? #f))
(home-page "https://www.tcpdump.org")
(synopsis "Network packet capture library")
(description
"libpcap is an interface for user-level packet capture. It provides a
portable framework for low-level network monitoring. Applications include
network statistics collection, security monitoring, network debugging, etc.")
-
- ;; fad-*.c and a couple other files are BSD-4, but the rest is BSD-3.
- (license license:bsd-3)))
+ (license (list license:bsd-4 ; fad-*.c and several other source files
+ license:bsd-3 ; pcap/, sockutils.* & others
+ license:bsd-2)))) ; the rest
(define-public tcpdump
(package