summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-05 09:59:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-05 09:59:27 +0200
commit66ece08d05825aaa52404b43b5083a0895d284be (patch)
tree3103dbefcf63b49f4c8192689797acb22cf21a1e /gnu/packages/admin.scm
parent8b71684a2086182528c16b5e21599013420ea84c (diff)
parent0ebef06dbe5e53025670a76ff98f05e8c093f013 (diff)
downloadpatches-66ece08d05825aaa52404b43b5083a0895d284be.tar
patches-66ece08d05825aaa52404b43b5083a0895d284be.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm32
1 files changed, 11 insertions, 21 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2583cc2018..f253fca57e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1265,7 +1265,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
(define-public acpica
(package
(name "acpica")
- (version "20180508")
+ (version "20180531")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1273,7 +1273,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
version ".tar.gz"))
(sha256
(base32
- "05fg4gcgs1jhh5ad71q1dr35vh119g8avjdy806q614yvgcwk3sx"))))
+ "0q7vg1nr51f3rg16vjh4glz361a64r6gpm46fqkl2jf4fq7g43g5"))))
(build-system gnu-build-system)
(native-inputs `(("flex" ,flex)
("bison" ,bison)))
@@ -2482,7 +2482,7 @@ make it a perfect utility on modern distros.")
(define-public thermald
(package
(name "thermald")
- (version "1.7.1")
+ (version "1.7.2")
(source
(origin
(method url-fetch)
@@ -2490,25 +2490,15 @@ make it a perfect utility on modern distros.")
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256 (base32
- "0isgmav3z3nb5bsdya8m3haqhzj1lyfjx7i812cqfjrh2a9msin4"))))
+ "15a6vb67y5wsmf0irrq7sxam18yqpz64130k83ryf24mp40h661b"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after
- 'unpack 'autogen.sh-and-fix-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; XXX this can probably be removed after version 1.7.1.
- ;; upstartconfir is hardcoded to /etc/init and the build
- ;; system tries to mkdir that. We don't even need upstart
- ;; files at all; this is a fast and kludgy workaround
- (substitute* "data/Makefile.am"
- (("upstartconfdir = /etc/init")
- (string-append "upstartconfdir = "
- out "/etc/init")))
- ;; Now run autogen
- (invoke "sh" "autogen.sh")
- #t))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (invoke "sh" "autogen.sh")
+ #t)))
#:configure-flags
(let ((out (assoc-ref %outputs "out")))
(list (string-append "--sysconfdir="
@@ -2530,7 +2520,7 @@ make it a perfect utility on modern distros.")
(synopsis "CPU scaling for thermal management")
(description "The Linux Thermal Daemon helps monitor and control temperature
on systems running the Linux kernel.")
- ;; arm and aarch64 don't have cpuid.h
+ ;; arm and aarch64 don't have cpuid.h.
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:gpl2+)))