summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-03-29 20:23:33 -0500
committerEric Bavier <bavier@member.fsf.org>2017-03-29 20:51:06 -0500
commitbf5b6fb294331f108cdb5b2555dd357f69321821 (patch)
tree413b2ac4efd7032472c36d61cd008e6eab7601aa /gnu/packages/admin.scm
parent6fd52309b8f52c9bb59fccffac53e029ce94b698 (diff)
downloadpatches-bf5b6fb294331f108cdb5b2555dd357f69321821.tar
patches-bf5b6fb294331f108cdb5b2555dd357f69321821.tar.gz
gnu: thefuck: Upgrade to 3.15 and enable tests.
* gnu/packages/patches/thefuck-test-environ.patch: New patch. * gnu/packages/admin.scm (thefuck): Upgrade to 3.15. [source]: Use patch. [arguments]: Remove '#:tests? #f'. Move 'check' phase after 'install'. * gnu/local.mk (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9dd664ef6b..8c8d1bc5f2 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2016 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Alex Sassmannshausen <alex.sassmannshausen@gmail.com>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -1688,7 +1688,7 @@ throughput (in the same interval).")
(define-public thefuck
(package
(name "thefuck")
- (version "3.11")
+ (version "3.15")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/nvbn/thefuck/archive/"
@@ -1696,19 +1696,20 @@ throughput (in the same interval).")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "04q2cn8c83f6z6wn1scla1ilrpi5ssjc64987hvmwfvwvb82bvkp"))))
+ "1vxas21h5mf41cb6y7f7x07858ags7qg45lkf74rc0slqbic3l1h"))
+ (patches (search-patches "thefuck-test-environ.patch"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f))
- ;; FIXME: 10 test failures. Some require newer pytest (> 2.9.2).
- ;; Others need more work. Un-comment the below to run the tests.
- ;; #:phases
- ;; (modify-phases %standard-phases
- ;; (replace 'check
- ;; (lambda _
- ;; ;; Some tests need write access to $HOME.
- ;; (setenv "HOME" "/tmp")
- ;; (zero? (system* "py.test" "-v")))))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Tests look for installed package
+ (add-installed-pythonpath inputs outputs)
+ ;; Some tests need write access to $HOME.
+ (setenv "HOME" "/tmp")
+ (zero? (system* "py.test" "-v")))))))
(propagated-inputs
`(("python-colorama" ,python-colorama)
("python-decorator" ,python-decorator)