summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorBen Sturmfels <ben@sturm.com.au>2017-11-07 23:37:38 +1100
committer宋文武 <iyzsong@member.fsf.org>2018-06-12 19:47:12 +0800
commite68e4a906f2a3ca74cf3f0ae9ddf7ad6d627b6ac (patch)
treefedc8e7aa7258eedd40429ea4b9d4a7a781bb6e7 /gnu/packages/admin.scm
parent7714a06943a46c6b1881e2514131c1946428d270 (diff)
downloadpatches-e68e4a906f2a3ca74cf3f0ae9ddf7ad6d627b6ac.tar
patches-e68e4a906f2a3ca74cf3f0ae9ddf7ad6d627b6ac.tar.gz
gnu: fabric: Disable problematic tests.
Reported by Ricardo Wurmus <rekado@elephly.net> at <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26647#8>. * gnu/packages/admin.scm (fabric): Add custom check phase to disable two tests.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6b8df3fb9b..6e9888cf3b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2359,11 +2359,23 @@ Intel DRM Driver.")
"13r0b0hllgf8j9rh6x1knmbgvingbdmx046aazv6vck2ll120mw1"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2)) ; Python 2 only
+ `(#:python ,python-2 ; Python 2 only
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke
+ "nosetests" "-v" "tests/"
+ ;; This test hangs indefinitely when run on a single core VM
+ ;; (see GNU bug #26647 and Debian bug #850230).
+ "--exclude=test_nested_execution_with_explicit_ports"
+ ;; This test randomly fails in certain environments causing too
+ ;; much noise to be useful (see Debian bug #854686).
+ "--exclude=test_should_use_sentinel_for_tasks_that_errored"))))))
(native-inputs
- `(("python2-fudge" ,python2-fudge)
- ("python2-jinja2" ,python2-jinja2)
- ("python2-nose" ,python2-nose)
+ `(("python2-fudge" ,python2-fudge) ; Requires < 1.0
+ ("python2-jinja2" ,python2-jinja2) ; Requires < 3.0
+ ("python2-nose" ,python2-nose) ; Requires < 2.0
("python2-pynacl" ,python2-pynacl)
("python2-bcrypt" ,python2-bcrypt)))
(propagated-inputs